Java and the recommendations that have been made

list list at
Thu Sep 30 07:59:38 UTC 2004

I have tried a few different things to get java going--but have no luck  

I tried adding the sources as suggested here  
and when I try to use synaptic I get the following errror:

Depends: sun-j2sdk1.4 but it is not installable

I also tried apt-get with these results:

dim:/usr/java/j2re1.4.2_05# apt-get install sun-j2re1.4debian
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
   sun-j2re1.4debian: Depends: sun-j2re1.4 but it is not installable
E: Broken packages

Is there any way to just use the .bin file from Since there is  
no root user, it doesn't seem to want to install to all the different  
directories... I could try hand placing all the files, but anytime I  
wanted to update, this would be a major hassle. I know that java is  
proprietary, but it would be great if there were an easier way to get it  



More information about the ubuntu-users mailing list