Compaq Armada Laptop

Benjamin Roe ben_ubuntu at
Mon Sep 27 17:06:50 UTC 2004

I actually seem to have got it working with "apm --suspend" now.

The trick was to put a script to change the virtual terminal away from 
the one X was running on with a "chvt 1" in the suspend script and 
change it back with "chvt 7" on resume. It's still a bit funny - the 
terminal I suspended from behaved as if I was holding the Enter key down 
until I pressed a key on resume, but it's worked several times now.


Lee Colleton wrote:

>On Mon, 2004-09-27 at 18:07 +0100, Benjamin Roe wrote:
>>Has anyone out there managed to get apm/acpi working properly with a
>>Compaq Armada laptop (I have the M300)? I really like Ubuntu and would
>>love to be able to use it on my laptop as well.
>>ACPI support seems not to work - I can put the laptop into sleep, but
>>trying to wake it up again with the power button just results in the
>>laptop flashing an orange LED twice and powering down. ACPI support has
>>always been a bit dodgy, though.
>>APM support in previous distros (including Debian Sarge) has worked fine
>>for standby and so on. In ubuntu, the system will go into standby but
>>then locks up on resuming.
>>Does anyone have any experiences or ideas for getting apm to work
>>Ben Roe
>I can second this with an IBM Thinkpad X30.  APM worked under Debian
>Sarge but even with the kernel option "acpi=off" and the APM module
>loaded I get a system lockup on resume.  I've tried this from both the
>console and from X.

More information about the ubuntu-users mailing list