XSane segmentation fault

June Tate june at theonelab.com
Tue Oct 26 22:43:43 UTC 2004


On Mon, 2004-10-25 at 16:02 -0700, June Tate wrote:
> Actually, I've already tried running it as root -- I had permissions
> problems before in Debian and quickly learned how to deal with it -- but
> I still get the segfault. I had this same scanner and same system
> working perfectly under Debian, so I already know that the scanner is
> supported by SANE. The issue is being caused by something in the
> preview_create_batch_icon() function in the xsane binary. I'm going to
> try to track this down myself by pulling the sources and compiling a
> debug version of it.
> 
> I have reason to suspect that this issue might be related to bug #1923
> (https://bugzilla.ubuntu.com/show_bug.cgi?id=1923), as I have
> experienced similar issues as described in the bug report in addition to
> the xsane issues.

Okay, so here's a note: don't use old xsane RC files. =op

I managed to fix the issue by removing the $HOME/.sane directory
entirely and rerunning xsane. Poof! It worked. =o)

-- 
June Tate * june at theonelab.com * http://www.theonelab.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20041026/0a11fbd1/attachment.pgp>


More information about the ubuntu-users mailing list