HELP!! User issue

Peter Hoffmann ph at
Tue Nov 23 06:00:34 UTC 2004

zer0halo wrote:
> I think I really blew it and I don't know my way out. When I installed
> Ubuntu I set up my user name, which I'll call "newlogin". However, I
> had previously used a different user name, and had shares on a remote
> server which were accessible by my former user name "oldlogin".
> So today I needed to access those files, and in Ubuntu I went into
> Users and Groups and decided to go into my "newlogin" user properties
> and rename it back to "oldlogin" (stupidly, instead of just creating
> another user).  Everything seemed fine until I tried to run sudo and
> got the error "user oldlogin not in sudoers file". Yikes. So because
> root is disabled in Ubuntu I can't get into root to change my user
> name back to what it was or to edit the sudoers file. Nor can I run
> any program that runs at root. So I'm stuck. I guess that's one
> disadvantage of having root disabled. Is there any way out of this
> besides having to reinstall from scratch (which I really don't have
> time to do!). Thanks for the help.

Reboot in recovery mode and you will get a root shell. To do so restart 
the computer and hit the Esc Butten when grub comes up to enter the grub 
menu. Then choose:
<your kernel> (recovery mode)

Peter Hoffmann <ph at>

More information about the ubuntu-users mailing list