Audio via PCI bus for BT87x cards (or missing /dev/dsp? devices)

laust. ladefoged laust.ladefoged at gmail.com
Thu Nov 18 22:42:03 GMT 2004


I am having trouble getting sound via the pci bus working with 2 bt878
tvcards. Video is working it is only the sound via pci I am having
trouble getting to work.

I tried to do a barebone install of the Warty prerelease (or release
candidate), and before doing apt-get dist-upgrade I had /dev/dsp1 and
/dev/dsp2 and /dev/dsp3. After the upgrade I only have /dev/dsp

All ideas on how to configure this is welcome.

Below you can see what dmesg has to say about the bttv setup. It looks
like the audio function is recognised but no devices are created.

- Laust.

bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:02:08.0, irq: 137, latency: 128, mmio: 0xfbffc000
bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
bttv0: using: Hauppauge (bt878) [card=10,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffdb [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
bttv0: Hauppauge eeprom: model=44314, tuner=Philips FM1216 (5), radio=yes
bttv0: using tuner=5
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tvaudio: TV audio decoder + audio/video mux driver
tvaudio: known chips:
tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54
(PV951),ta8874z
tuner: chip found at addr 0xc2 i2c-bus bt878 #0 [sw]
tuner: type set to 5 (Philips PAL_BG (FI1216 and compatibles)) by bt878 #0 [sw]
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: registered device radio0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv: Bt8xx card found (1).
bttv1: Bt878 (rev 17) at 0000:02:0a.0, irq: 153, latency: 128, mmio: 0xfbffe000
bttv1: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
bttv1: using: Hauppauge (bt878) [card=10,autodetected]
bttv1: gpio: en=00000000, out=00000000 in=00ffffdb [init]
bttv1: Hauppauge/Voodoo msp34xx: reset line init [5]
tuner: chip found at addr 0xc2 i2c-bus bt878 #1 [sw]
bttv1: Hauppauge eeprom: model=61344, tuner=Philips FM1216 (5), radio=yes
bttv1: using tuner=5
tuner: type set to 5 (Philips PAL_BG (FI1216 and compatibles)) by bt878 #1 [sw]
bttv1: i2c: checking for MSP34xx @ 0x80... found
msp34xx: init: chip=MSP3415D-B3 +nicam +simple
msp3410: daemon started
bttv1: i2c: checking for TDA9875 @ 0xb0... not found
bttv1: i2c: checking for TDA7432 @ 0x8a... not found
bttv1: registered device video1
bttv1: registered device vbi1
bttv1: registered device radio1
bttv1: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
bt878(0): Bt878 (rev 17) at 02:08.1, irq: 137, latency: 32, memory: 0xfbffd000
bt878: Bt878 AUDIO function found (1).
bt878(1): Bt878 (rev 17) at 02:0a.1, irq: 153, latency: 32, memory: 0xfbfff000




More information about the ubuntu-users mailing list