[ubuntu-us-ut] trying to create karmic usb install

MilesTogoe miles.togoe at gmail.com
Thu Oct 15 20:35:28 BST 2009

On 10/15/2009 11:54 AM, Adam Olsen wrote:
> On Thu, Oct 15, 2009 at 12:15 PM, MilesTogoe<miles.togoe at gmail.com>  wrote:
>> I'm trying to create a karmic install usb stick from an iso on my netbook
>> (no dvd drive available).  I've downloaded the cdlive tools but when I went
>> to create my usb drive it was stuck with GPT - anyway I tried to reformat
>> and hosed the flash drive - now when I stick in the usb drive and do "df" I
>> see tempfs and nothing else.  But when I try to run parted I'm caught in
>> this loop of not having a partition, .....
>> Is there some easy way I can simply start over with my flash drive ?  ie
>> create partition, format , .....   I think once I get that far I can run
>> parted to create the partition as bootable and run livecd-tools to create
>> the install disk.
> Unplug your usb drive, and plug it back in.  Type "dmesg", it should
> give you some device information.  You'll see something like this:
> [69192.265021] sd 9:0:0:0: Attached scsi generic sg3 type 0
> [69192.266317] sd 9:0:0:0: [sdc] 3948544 512-byte logical blocks:
> (2.02 GB/1.88 GiB)
> [69192.267006] sd 9:0:0:0: [sdc] Write Protect is off
> [69192.267011] sd 9:0:0:0: [sdc] Mode Sense: 00 00 00 00
> [69192.267015] sd 9:0:0:0: [sdc] Assuming drive cache: write through
> [69192.269133] sd 9:0:0:0: [sdc] Assuming drive cache: write through
> [69192.269138]  sdc: sdc1
> Maybe without the sdc1, but you'll know that your device is /dev/sdc,
> at which point you can run parted on /dev/sdc, or fdisk, and create a
> new partition table or partition.

thks - dmesg  is showing /dev/sdb1 (which is what I've been 
specifying).  I ran parted again and now using print I see the 
partition, and boot flag for sdb1 - all looks well.

but when i do "df" still does not show (just shows as tempfs  
/dev/shm).  When I run livecd-iso-to-disk it appears to install 
(removing old os, ) but not sure if it's adding the whole iso 
package.    If I boot on it, it just beeps at boot menu (the same iso 
boots okay from cd on my other macbook).  I get the feeling it doesn't 
have the vmlinux startup files but don't know how to check since the dev 
doeesn't seem to mount.

any other suggestions ?  thks.

More information about the ubuntu-us-ut mailing list