[ubuntu-us-ut] [SOLVED] Re: Mail from localhost delivered to Google Apps with Postfix? Anyone have a solution?

chad at planetmayfield.com chad at planetmayfield.com
Mon Feb 18 19:39:09 GMT 2008

Thank you all that helped me figure this issue out with their  
suggestions.  I have, after some headaches, gotten this to work.  As I  
has suspected it had to do with the TLS handshake with Gmail.  I used  
Google to find quite a few instances of people doing close to the same  
thing.  Overall what i did was this;

Make myself a CA
Make a Cert and sign it as the CA
Within Postfix:
   Create a generic file with my local aliases and deliverable  
   Cretae a transport file with my domain and gmail's smtp port (I was  
getting this wrong in my first installation)
   Create the sasl_passwd file with my Gmail (Google Apps) email  
address and password.
   Hash the files (I forgot to hash one once in my troubleshooting)

After I had done that I could actually tail the logs and see the  
handshake occurring.  So it is fixed and I am receiving mail!  The  
interesting thing is that it appears (obviously I could be wrong) that  
Gmail requires a TLS connection for mail that is relayed.  So just  
adding a ~/.forward or an alias was not working.

If anyone is interested I will be writing up a small tutorial on what  
I did in order to get it working and it will be posted some time this  
week.  You will be able to read it here (http://www.planetmayfield.com/linux-unix/using-postfix-to-relay-local-mail-to-google-apps/ 

Again thanks for all the suggestions.

Chad R Mayfield
chad at planetmayfield.com
GPG Key: 0C9A026F

On Feb 16, 2008, at 2:37 PM, chad at planetmayfield.com wrote:

> Greetings All,
> So I have been on SLLUG, PLUG, and the Ubuntu Utah lists for quite  
> awhile under different addresses, but have not posted a questions  
> yet, some responses, but no questions.  I have enjoyed learning with  
> everyone's posts but finally find myself needing help that I cannot  
> resolve with Google's help alone, hopefully someone here can help.
> On the main domain I host I use Google Apps for email only rather  
> than have to administer a mail server a deal with spam issues,  
> relays, etc..  The problem I am running into is that I need the  
> local mail generated by localhost to be relayed/forwarded to my  
> Google Apps account.  My MX records are pointed toward Google's mail  
> servers, while my domains A record is are pointed to the physical  
> server via ZoneEdit.  The longer the server is around and the more  
> projects I work on the more I have realized I need that local mail  
> to be delivered to my normal email for debugging of applications,  
> logwatch, etc...
> I was trying to use Postfix following several similar users' issues  
> online.  (Relaying local mail to Gmail/Google Apps using Postfix).   
> Some of the tutorials I have tested are; The Prancing Tarantula (http://prantran.blogspot.com/2007/01/getting-postfix-to-work-on-ubuntu-with.html 
> ), Setting up Postfix to relay through Gmail (http://www.darryl.cain.com.au/postfix/ 
> ), and How to relay mail using Ubuntu, Postfix, and Gmail (http://kirranet.co.nz/content/howto-relay-email-using-ubuntu,-postfix-and-gmail 
> ).  None have worked.
> I can get Postfix to say the message was sent, yet it never leaves  
> the local mailbox, and it is nowhere to be found.  From the  
> tutorials I have learned there is an issue with Google and TLS so a  
> certificate needs to be created.  A simple relay will not work.  So  
> my problem still stands, i cannot get local mail relayed/forwarded.   
> Does anyone have any ideas how I can relay local mail delivered to,  
> say root, to my Google Apps account?  Anyone?
> Server Info: Ubuntu 7.10 Server
> ---
> Chad R Mayfield
> chad at planetmayfield.com
> GPG Key: 0C9A026F
> http://www.planetmayfield.com/
> http://www.chadmayfield.com/
> ______________________________________________________________________
> See http://www.sllug.org/ for latest SLLUG news, information, links.
> Join SLLUG and other UT LUG members on irc.FreeNode.net channel #Utah
> sllug-members at sllug.org
> http://www.sllug.org/cgi-bin/mailman/listinfo/sllug-members

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-us-ut/attachments/20080218/e20f6dd6/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3821 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/ubuntu-us-ut/attachments/20080218/e20f6dd6/attachment.bin 

More information about the ubuntu-us-ut mailing list