Trouble with wifi on WPA encrypted network

Kenneth Adam Miller kennethadammiller at
Thu Aug 19 06:16:02 BST 2010

Hi, I'm using Ubuntu 10.04
I'm having trouble staying connected to a wifi network as the subject of my
email describes. To give you more detail, I will say that what is happening,
is I will suddenly stop receiving data packages. Network Monitor does NOT
detect that I am disconnected. I haven't been patient enough to see if it
will reconnect on it's own, because simply going up to NM in the top bar and
selected the wireless that I want again does the trick. But I don't want to
continually have to deal with this problem.

Among the things that I have tried after following some of the forum posts
that I have discovered with research are updating the kernel and creating a
file /etc/modprobe.conf and placing the lines

alias wlan0 iwlagn
options iwlagn swcrypto50=1 swcrypto=1

inside. I also placed this short line inside the file I created under
"/etc/pm/config.d/00sleep_modules": SUSPEND_MODULES="ath9k"

None of these have fixed the problem.

Dmesg | tail reports this:

In particular, this line has drawn my attention: [ 2134.207681] wlan0:
deauthenticating from 30:46:9a:3d:b2:1a by local choice (reason=3)

I am on an Acer 5740-6025 laptop. The wifi card is supposed to be this:
04:00.0 Network controller: Atheros Communications Inc. AR928X Wireless
Network Adapter (PCI-Express) (rev 01)

Does anyone know why this is happening? or what I can do to fix this?
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Ubuntu-us-tx mailing list