James Bradley jim at oregoncanoesport.com
Fri Nov 4 22:57:15 UTC 2011

I was able to access the HP s5-1110 today and run the UF tests. As might 
be expected, since none of the tests really address the issue of writing 
to the boot partition, nothing particularly useful resulted. All the 
tests I ran, (I didn't have some of the pluggable devices to test), 
worked just fine.

More tellingly, I then used the SuperGRUB 2 disk to search the drive for 
OSes for boot. It easily located the Kubuntu installation on its logical 
partition, (the disk has 3 primary partitions used by Windows for the 
boot, the main OS and the restore partitions, and one extended partition 
with its one logical partition holding Kubuntu), and booted Kubuntu 
normally from there. There is nothing to suggest Kubuntu is anything 
less than fully functional, once booted.

Again, the issue seems to be something preventing GRUB from installing 
on the boot partition. Both the Kubuntu installer and the Boot Repair 
disk appeared to correctly identify the Windows boot partition as the 
target for GRUB installation, but it would seem clear the installation 
of GRUB, and only GRUB, fails.

I remain ready to try grub-install from the command line, if you think 
that will offer any different results, but at this point evidence 
suggests it would be flogging a dead horse.


On 11/02/2011 04:25 PM, Allison Randal wrote:
> This is perfect, thanks! A bunch of us are at UDS this week, so I'm
> collecting details. One useful piece, next time you get access to the
> hardware, since the CD boots, you can run the Ubuntu Friendly tests
> straight from the Live CD session:
> http://friendly.ubuntu.com/participate/
> That can track down more detail on where the failure might be.
> Looks like I might get access to similar hardware next week, as well.
> Allison
> On 10/31/2011 11:53 AM, James Bradley wrote:
>> Thank you very much for your attention in this matter, Allison.
>> This page at HP's site has the most complete specifications I can find:
>> http://h10010.www1.hp.com/wwpc/ca/en/ho/WF06b/12454-12454-3329740-64546-64546-5146457-5157056.html
>> The machine is not in my possession, so I can't immediately access it,
>> (I'm helping a friend set it up). If there is more information you need,
>> like BIOS rev number or such, let me know and I'll try to get it for you.
>> I'm not sure how many details have been forwarded to you, so let me
>> briefly recap. Kubuntu 11.10-64 installs on its partition without
>> apparent problem. The installer identifies the separate boot partition
>> used by Win 7 as the target for GRUB and the installation appears to
>> progress normally. Upon attempting to reboot, GRUB's menu never appears
>> and the machine boots straight into Windows. Attempts to install GRUB
>> using the Boot Repair disk appear to run normally, giving no errors, but
>> upon reboot the machine again immediately boots Windows.
>> It would certainly seem that it is GRUB which is failing to install. I
>> can try to install using the command line, if you think that will be
>> helpful. Please let me know if there are any special parameters which
>> should be passed to grub-install in such an attempt. Perhaps I should
>> add, there is an entry in the BIOS labeled "UEFI", but selecting it
>> produces no response.
>> It should be noted that HP consumer tech support was not knowledgeable
>> on the issue and was blocked from querying business tech support by
>> internal policy. Perhaps you can wield sufficient clout to obtain a
>> better result.
>> Again, thank you for your time and attention in this matter.
>> On 10/31/2011 07:43 AM, Allison Randal wrote:
>>> This is almost certainly a problem with some hardware component in the
>>> system. UEFI has been around a long time, and is compatible with Linux
>>> (including Ubuntu). The Secure Boot feature was just introduced in the
>>> UEFI v2.3.1 specification released in April 2011, and the hardware
>>> vendors are still working on implementation. So, UEFI Secure Boot isn't
>>> shipping in current hardware.
>>> JVLB, if you let me know a little more about the specs of your system, I
>>> can look up the components in our hardware database
>>> (http://hwdb.ubuntu.com/) and see if we can pinpoint a likely cause of
>>> failure.
>>> Allison
>>> On 10/30/2011 07:48 PM, Benjamin Kerensa wrote:
>>>> Hey JVLB,
>>>> So the UEFI issue you were having which I shared on my blog is getting
>>>> around the entire FOSS community (So far Mandriva Forums, Linux Mint
>>>> Forums, Ubuntu Forums and every social network site) anyways a Ubuntu
>>>> member suggested trying a 64bit image for the install and also you might
>>>> try a alternate ISO if you haven't already.
>>>> There is some concern that it might be a Ubuntu bug instead of
>>>> UEFI/Secure Boot.
>>>> -- 
>>>> bkerensa

More information about the Ubuntu-us-or mailing list