[ubuntu-us-mn] How to get WINE to update in Ubuntu Hardy (8.04)

Chuck Cole cncole at earthlink.net
Thu Aug 28 21:29:37 BST 2008

> -----Original Message-----
> From: Richard Laager [mailto:rlaager at wiktel.com]
> Sent: Thursday, August 28, 2008 2:00 AM
> To: Chuck Cole
> Cc: ubuntu-us-mn

I must have several setup "anomalies" because nothing "normal" for this WINE update is working.  Did have a WiFI setup anomaly from
a working prior version, but got that fixed and most other things and updates seemed fine until I started trying to resolve a minor
problem with Notepad in WINE v 0.9.59 that is rumored to have been fixed by rev 1.x

Did as you suggested first, and tried to get update manager to help, but had no luck.
My notes are below in replies to your suggestions.

> On Thu, 2008-08-28 at 01:43 -0500, Chuck Cole wrote:
> > That instruction doesn't identify explicit paths or explicit file names for the pasting
> > unless I'm more blind than I thought.
> You keep mentioning files. I think the problem is that you think you
> need to paste those lines into files, where they're really commands to
> paste into the terminal (that you open via Applications -> Accessories
> -> Terminal).

Tried that first.  That didn't work.  Asked Linux system guy who is not an Ubuntu user: he agreed with my suggestion that it might
be intended as a paste into a script file of some sort since direct command line usage would not work.

> I'm feeling particular verbose for almost 2:00 am, so here's a breakdown
> of these steps:

Thanks VERY much for your time and patience to help with this!  I tried everything and a little more before responding.

> On Wed, 2008-08-27 at 18:03 -0500, Chuck Cole wrote:
> > First, open a terminal window (Applications->Accessories->Terminal).
> > Then ... copy and pasting the following
> [into the terminal window]
> >       wget -q http://wine.budgetdedicated.com/apt/387EE263.gpg -O- | sudo apt-key add -

Fails with message:  "gpg: no valid OpenPGP data found."

Have looked for possible alternatives or remedies for that, but I found none.

> So, in summary, this command pipeline downloads a file from
> wine.budgetdedicated.com and adds it to your trusted apt list. You're
> saying that you trust anything signed by that key, so be aware of the
> security implications there.
> >        sudo wget http://wine.budgetdedicated.com/apt/sources.list.d/hardy.list -O /etc/apt/sources.list.d/winehq.list
> This is the same sort of thing. It's downloading a file from that same
> domain and adding it to APT. This means they'll be able to provide
> packages to be installed on your system. Again, try to keep in mind the
> security implications here.

No result, but no error message either.

> ******** IMPORTANT ********
> I would recommend you skip that stuff for now anyway, and try to figure
> out why you're not getting the newer version of wine from hardy-updates.
> See below:
> Regarding hardy-updates, try running a command like this:
>         grep 'hardy-updates.*universe' /etc/apt/sources.list | grep -v
>         "^#"

Zero response.

> If that returns nothing, the hardy-updates repository is NOT enabled, at
> least not for the universe section. Try following the first method
> described in these instructions:
> http://www.ubuntugeek.com/how-to-enable-the-universe-and-multiverse-repositories-in-ubuntu-804-hardy.html

Both universe and multiverse were already enabled and had always been enabled.

I changed the download server from an ambiguous "standard server" reference to an explicit ref to mirror.imbrandon.com and that had
no more effect than to require an update of download options that did not make any change to the WINE version from 0.9.59

I tried to activate the "forced version" option mentioned in those instructions as a way to designate a different  or specific
version, but I cannot enable that function with any fiddling around or basic "help" checks.  Nothing has changed the update version
from the choice of 0.9.59

> If it returns a line like this, I have no idea what the issue is:
>         deb http://us.archive.ubuntu.com/ubuntu/ hardy-updates universe

As noted, zero response.

I must have several setup anomalies remaining.  Hope you can spot something from my notes above.  Maybe Brian has clues from what he
saw before.  When I upgraded to Ubuntu 8.04 (using an online update), my WiFi install, permissions and setups (and maybe other
stuff) was regressed to less than was installed and working before.  Brian found that a puzzling situation and he quickly located
those parameters which had become commented out, and not by my doings.  That was more than just a setup omission because I could not
identify the installed and previously working internal WiFi that still worked fine when I ran Windows XP.  Only WiFi was affected,
my wired LAN connection and some other driver/setup stuff was fine.  Did not notice any other setup or I/O anomalies then or since.


More information about the ubuntu-us-mn mailing list