[ubuntu-us-mi] Java Plugin for Firefox on Ubuntu Lucid x64

Robert Citek robert.citek at gmail.com
Tue May 18 23:07:54 BST 2010


How does one go about installing the Java plugin for Firefox on Ubuntu Lucid?

I visit this one particular URL and get this page:

<quote>
Java Plugin not found.

The minimum Java plugin version required is 1.4.2_01.

Due to a security vulnerability reported with Java plugin versions
prior to 1.4.2_11b01, it is highly recommended that you install Java
plugin version 1.4.2_11b01 or higher.
<quote>

I've googled for "ubuntu firefox java plugin" and haven't found
anything that looks reasonably current or helpful.  I've tried
installing Java, but I still get the error page:

$ dpkg -l | grep -i java
ii  ca-certificates-java                   20100406ubuntu1
                    Common CA certificates (JKS keystore)
ii  default-jre                            1.6-34
                    Standard Java or Java compatible Runtime
ii  default-jre-headless                   1.6-34
                    Standard Java or Java compatible Runtime (he
ii  java-common                            0.34
                    Base of all Java packages
ii  libaccess-bridge-java                  1.26.2-3
                    Java Access Bridge for GNOME
ii  libaccess-bridge-java-jni              1.26.2-3
                    Java Access Bridge for GNOME (jni bindings)
ii  libjs-jquery                           1.3.3-2ubuntu1
                    JavaScript library for dynamic web applicati
ii  openjdk-6-jre                          6b18-1.8-0ubuntu1
                    OpenJDK Java runtime, using Hotspot JIT
ii  openjdk-6-jre-headless                 6b18-1.8-0ubuntu1
                    OpenJDK Java runtime, using Hotspot JIT (hea
ii  openjdk-6-jre-lib                      6b18-1.8-0ubuntu1
                    OpenJDK Java runtime (architecture independe
ii  tzdata-java                            2010i-1
                    time zone and daylight-saving time data for

This particular machine is running Lucid x86_64:

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 10.04 LTS
Release:	10.04
Codename:	lucid

$ uname -a
Linux lucid 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC
2010 x86_64 GNU/Linux

Anyone have any pointers or suggestions?

Regards,
- Robert



More information about the ubuntu-us-mi mailing list