[ubuntu-us-ma] "Video Killed the Radio Star..."

Doc Kinne kinnerc at gmail.com
Wed May 6 19:53:59 BST 2009


Martin:

On 06 May , 2009, at 14:26, Martin Owens wrote:
> the xorg conf is meant to be empty, it's mostly generated on the fly
> these days.

Yea, I saw that, but I expected SOMETHING there. I'm not sure where  
else that data would be kept.

> It sounds like the xrandr can't get your monitor specs,

Never used the program before, but I agree with you, yes.

> so I hope you have them to hand.

Ummmmm.  :-(  It's an on-board video circuit going to an Envision  
multisync monitor.  :-\

> You can either repair the link between your video
> card and monitor (in order to enable i2c/ddc) or manually put the
> details into xorg conf and wire everything up yourself.
>
> I'd go for getting the drivers for your video card right, what are  
> they?

At this point I'm assuming I can use the vesa driver.

Unless anyone else comes up with some particular ideas I'm first going  
to see if I can install 8.04 on it. If that doesn't work, I'll  
reinstall Fedora 10 on it and see what kind of data I can get from  
that installation before trying Ubuntu again.
---
Richard "Doc" Kinne • Rikardo «Dokĉjo» KINNE, BA, MSc., AMAAS
<kinnerc @ gmail.com>
"I'm the Doctor, and you're in the biggest library in the universe.  
Look me up!"
- The Doctor
"Forests of the Dead," Doctor Who

> On Wed, 2009-05-06 at 10:33 -0400, Doc Kinne wrote:
>> Hi Guys:
>>
>>
>> Boy, that subject line really dates me, doesn't it?  :-)
>>
>>
>> I have to say that 9.04 is batting 0 for me at this point. I tried to
>> upgrade my Xubuntu installation on my Dell Inspiron 7000 laptop and  
>> it
>> would not boot up. Mike rolled his eyes at an "upgrade," and there is
>> part of me that understands that. I re-installed 8.10 on it and its
>> working as well as it ever did with Xubuntu. My next step there will
>> be to install 9.04 and see if that makes a difference.
>>
>>
>> But that's a back-burner project to be honest. This particular email
>> is about Ubuntu 9.04 on a desktop.
>>
>>
>> The desktop is an HP Vectra 550MHz PIII, 0.5GB RAM, an onboard VGA
>> video port. It was, until last night, blissfully running Fedora 10. I
>> decided to try to but Ubuntu 9.04 on it.
>>
>>
>> The install seemed to go as I expected it to with no problems.
>> However, when the machine rebooted the video no longer worked.
>>
>>
>> The machine would boot up and give the "Ubuntu" logo with the "moving
>> underline" indicating boot up progress. 90% the way through that line
>> the monitor would ker-chunk as it tried to move to a different
>> resolution (at least I think thats what its doing. It sounds like
>> there are some heavy relays moving, and moving those relays is usual
>> behavior for this particular Envision monitor). What gdm was doing  
>> was
>> trying to find a resolution and scan rate that made sense to it. It
>> would never find it and it would finally give up and throw up a  
>> dialog
>> box saying that Ubuntu was in "Low Graphics Mode" and offer ways to
>> debug the situation.
>>
>>
>> Going into console mode I checked /etc/X11/xorg.conf and found it
>> either empty or having nothing of substance in it. Looking at the  
>> logs
>> is how I found out that gdm was unsuccessfully trying to find a  
>> proper
>> resolution and scan rate.
>>
>>
>> • I tried running "xrandr" but it consistently said it could not  
>> open
>> the display.
>>
>>
>> • I tried reinstalling gdm. It would reinstall with no problem. The
>> only question regarding the display it would ask me would be if I
>> wanted to use the frame rate buffer or not. I tried both "yes" and
>> "no" with no effect.
>>
>>
>> • I tried dpkg-reconfigure -phigh xserver-xorg, but that just  
>> seemed
>> to give me a xorg.conf with basically empty entries in it.
>>
>>
>> • At one point, when I had killed the gdm process I just invoked
>> "startx" from the console. And it came up! I thought I was getting
>> somewhere. I went to the Display control panel and it said the  
>> monitor
>> resolution was 800x600 with a 60Hz signal. OK, it wasn't the 1024x768
>> that I was used to, but it worked. I applied the changes, and it
>> seemed to take it. However upon rebooting the display no longer
>> worked.
>>
>>
>> • I tried hand editing xorg.conf putting in a display resolution of
>> 800x600 and a driver of vesa (since in the logs it looked like it was
>> trying to use that driver), but that didn't work either.
>>
>>
>> Any thoughts from you guys? I'm stumped at this point. I've not had a
>> problem like this since the late 90s. It really confuses me that gdm
>> cannot find a good resolution, but startx tries twice and does it.  
>> But
>> I can't get those parameters to stick via the Display Control Panel.
>>
>>
>> The only thing *I* can think of right now is to try to install 8.04  
>> or
>> 8.10 and see if I have better luck there.
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-us-ma/attachments/20090506/36a2d2a2/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 155 bytes
Desc: This is a digitally signed message part
Url : https://lists.ubuntu.com/archives/ubuntu-us-ma/attachments/20090506/36a2d2a2/attachment-0001.pgp 


More information about the Ubuntu-us-ma mailing list