[Ubuntu Chicago] Riddle me this

Jim Campbell jwcampbell at gmail.com
Sun Nov 11 17:54:27 GMT 2007


For people interested in switching from Windows to Ubuntu, the Ubuntu
documentation has a section on "switching."

https://help.ubuntu.com/7.04/windows/C/

That section is from the Feisty documentation, but I don't think the docs
for that section changed much, if at all, for the Gutsy release.  They just
haven't uploaded the Gutsy documentation to the website yet.

Also, the Wireless Troubleshooting Guide is very helpful . . .  it is likely
difficult to understand for someone who is just starting out with Linux . .
. .

https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide

Still, it gets the job done.

Jim

On Nov 11, 2007 2:42 PM, Chad Sutton <chadarius at gmail.com> wrote:

> Freddy Martinez wrote:
> > Are their wireless drivers enables?
> >
> >
> The two things that I do all the time to screw up my wireless setup is...
>
> 1. Forget that I've turned off the wireless on the laptop with the switch.
> How to resolve? Turn on the wireless networking switch! On Dells this is
> usually FN+F2.
>
> 2. Tried to set some network card setting manually which makes
> knetworkmanager ignore that network card and stop working.
> For this I run the following commands to make sure everything is working
> properly. This assumes that your wireless card is eth1 (with eth0 being
> the wired network card).
>
> If your /etc/network/interfaces file has anything in it besides the lo
> interface then you should remark it out. This will allow your graphical
> network card manager. If your drivers are all installed and working than
> this will fix it pretty quickly.
>
> sudo nano -w /etc/network/interfaces
>
> This is my file. You can see where I've remarked out all the network
> card lines with a #.
> ---Begin File---
> auto lo
> iface lo inet loopback
> address 127.0.0.1
> netmask 255.0.0.0
>
> #iface eth0 inet dhcp
> #auto eth0
>
> #iface eth1 inet dhcp
> #auto eth1
> ---End File---
>
> If that doesn't work than there may be a problem with your driver.  In
> Gutsy I finally was able to ditch ndiswrapper with my Broadcom 43xx
> wireless card. To check whether my driver is loaded I run the following
> command:
>
> lsmod |grep bcm43xx
>
> Which returns:
> bcm43xx               127336  0
> ieee80211softmac       31360  1 bcm43xx
> ieee80211              35656  2 bcm43xx,ieee80211softmac
>
> I know its loaded when I see some lines returned. Your network card
> driver may be different. For instance if your laptop is using the Intel
> Centrio chip set it would be ipw2200 instead of bcm43xx. If you are
> using NDISWrapper than ndiswrapper is the driver you need to load.
>
> If the driver isn't loaded (no lines are returned from the last
> command), try loading it manually by running the following command:
>
> sudo modprobe bcm43xx
>
> Again, replace the network card driver with your specific driver.
>
> Once you know your driver is loaded, you can check to see if your
> wireless card can see networks. Do do this, run the following command:
>
> iwlist eth1 scan |grep ESSID
>
> This will return a list of all the wireless networks it can see. If its
> not working the list will be blank. You can also get rid of the "|grep
> ESSID" part of the command to see all the other detailed information.
>
> If you can see networks with the scan than your driver is loaded and
> working.
>
> --
> Later,
> Chad Sutton
> csutton at chadarius.com
> http://chadarius.com
> http://stephandchadsutton.com
>
>
> --
> Ubuntu-us-chicago mailing list
> Ubuntu-us-chicago at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-us-chicago
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-us-chicago/attachments/20071111/bea8ea37/attachment.htm 


More information about the Ubuntu-us-chicago mailing list