[Bug 530829] Re: Authorizations is old and should be hidden

Martin Pitt martin.pitt at ubuntu.com
Wed Mar 3 08:52:00 GMT 2010


I'm actually considering solving this in a slightly more radical way. I
examined the remaining reverse dependencies of policykit-gnome, and it's
not a lot.

reverse dependency tree:

policykit-gnome
  gnome-lirc-properties
  gnome-mount
    gnome-volume-manager
      libipoddevice
        hipo
  xubuntu-desktop
  xorg-options-editor-gtk
  gnome-api-docs (on -doc)

 * gnome-mount and gnome-volume-manager are obsolete and should just be removed.
 * libipoddevice should drop the g-v-m/hal recommends, they are obsolete and handled by gvfs/udisks now
 * xubuntu-desktop should drop its policykit-gnome dependency, I doubt that they use it for anything.
 * xorg-options-editor-gtk sounds old fashioned and could just go; I asked Bryce/Alberto about this
 * Once the previous things are solved, gnome-api-docs can drop its dependency on policykit-gnome-doc

Once that's done, policykit-gnome can be removed from lucid, and
policykit-1-gnome can get a Conflicts:/Replaces: to clean up policykit-
gnome on upgrades.

Thoughts?

** Also affects: xubuntu-meta (Ubuntu)
   Importance: Undecided
       Status: New

-- 
Authorizations is old and should be hidden
https://bugs.launchpad.net/bugs/530829
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list