[Bug 524183] [NEW] Sync hamlib 1.2.10-1 (universe) from Debian unstable (main)

Launchpad Bug Tracker 524183 at bugs.launchpad.net
Fri Feb 19 01:33:18 GMT 2010


You have been subscribed to a public bug by Kamal Mostafa (kamalmostafa):

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/hamlib
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors
 done

Please sync hamlib 1.2.10-1 (universe) from Debian unstable (main)

Justification for FFE:

    The 'hamlib' package provides core ham radio "rig control" libraries used
    by virtually all the ham radio applications which offer rig control.

    Upstream development of hamlib has been very active [1,2] but Debian and
    Ubuntu have been stuck on an old version for about a year, due to the
    retirement of the main Debian uploader for the package.  (I have assumed
    that role; the 1.2.10-1 release proposed for sync is my packaging).

    The new hamlib 1.2.10-1 release at Debian delivers support for many new
    ham radio models and important fixes for numerous other radio models.

    I have tested the 1.2.10-1 release in Lucid.  The package builds and
    installs fine [3,4].  I have attached the ouput from a simple library
    test of hamlib's CLI utility 'rigctl' [5].   I have also tested the
    library with actual ham radios and other applications which use hamlib
    (fldigi, grig, my own code).

    Attachments:
    [1] hamlib-1.2.10-1-NEWS  (new NEWS entries)
    [2] hamlib-1.2.10-1-new_upstream_ChangeLog  (new ChangeLog entries)
    [3] hamlib_1.2.10-1-pbuilder-lucid.log
    [4] hamlib-1.2.10-1-install.log  (install log on Lucid)
    [5] hamlib-1.2.10-1-rundemo.log  (simple library test)

Explanation of the Ubuntu delta and why it can be dropped:

    The Ubuntu delta 1.2.9-1ubuntu1 ("Python 2.6 transition") has
    been ported to this version.

Changelog entries since current lucid version 1.2.9-1ubuntu1:

hamlib (1.2.10-1) unstable; urgency=low

  * New upstream release.
  * New maintainer: Kamal Mostafa <kamal at whence.com> (Closes: #556098).
  * Use system libltdl not old internal copy CVE-2009-3736 (Closes: #559814):
    - Build-depend on libltdl3-dev
    - configure, Makefile.am, Makefile.in: skip internal libltdl build
  * Enable hamlib USB support: configure with LIBUSB_LIBS predefined.
  * Enable hamlib Tcl bindings: configure with --enable-tcl-binding.
  * Debian Standards-Version bump to 3.8.4.
  * Python 2.6 transition [Michael Bienia <geser at ubuntu.com>].

 -- Kamal Mostafa <kamal at whence.com>  Tue, 16 Feb 2010 18:56:10 -0800

hamlib (1.2.9-2) unstable; urgency=low

  * Retiring - set the package maintainer to Debian QA Group.

 -- Joop Stakenborg <pa3aba at debian.org>  Sun, 01 Nov 2009 19:30:20 +0000

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)

iEYEARECAAYFAkt96dIACgkQI05zFCxp4Q8W3QCfRy0XkLxfF8Qj17TkBScIjTiw
p3QAmwY/zfWSS3rp/jpzhr670nCkrsYk
=kuuE
-----END PGP SIGNATURE-----

** Affects: hamlib (Ubuntu)
     Importance: Wishlist
         Status: New

-- 
Sync hamlib 1.2.10-1 (universe) from Debian unstable (main)
https://bugs.launchpad.net/bugs/524183
You received this bug notification because you are a member of Ubuntu Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list