[Bug 495507] Re: Hydrogen-0.9.4-1 sync request Sid (unstable) -> Lucid

Daniel Holbach daniel.holbach at ubuntu.com
Wed Feb 17 09:39:18 GMT 2010


ACKed.

** Description changed:

- sync request for Hydrogen-0.9.4-1 from Debian Sid (unstable) -> Lucid
+ hydrogen (0.9.4-1) unstable; urgency=low
  
- current version in Ubuntu is Hydrogen-0.9.3
+    * New upstream release. Closes: bug#551839, thanks to Larry Holish.
+      + Apparently solves startup crash on AMD64. Closes: bug#402635,
+        thanks to Simon Guest.
+      + Uses splash screen (not intro dialog too wide for some screens).
+        Closes: bug#501044, thanks to Klaus Ade Johnstad.
+    * Adopt package: Set Debian Multimedia team as maintainer, and myself
+      as uploader.
+    * Package now git-maintained: Add Vcs-* stanzas to control file.
+    * Add README.source, documenting CDBS, git-buildpackage and
+      DEB_MAINTAINER_MODE.
+    * Add and make use of local CDBS snippets:
+      + upstream-tarball.mk
+      + buildinfo.mk.
+      + copyright-check.mk.
+      + package-relations.mk.
+      + scons.mk (replacing autotools.mk).
+    * Repackage using source format '3.0 "quilt"'.
+    * Drop some patches:
+      + 00: Upstream manuals now include proper charset declaration.
+      + 01: Promoting Debian maintainance unnecessary, and might be
+        inaccurate (patch have been wrong for several years).
+      + 04: Improved FLAC support adopted upstream now.
+      + 05: No longer applying (apparently fixed upstream).
+      + 06: No longer applying.
+    * Refresh remaining patches and uniform to always strip a single
+      prefix (i.e. 'patch -p 1').
+    * Unfuzz and update file locations of patches 02 and 08.
+    * Disable patches 02, 03, 07 and 08 (all compilation fixes), possibly
+      no longer needed.
+    * Add patches 09 and 10 adjusting PortAudio and PortMIDI support to v2
+      API.
+    * Build-depend on libtarchive-dev, port19audio-dev, libportmidi-dev,
+      liblash-dev and libqt4-dev (and not libqt3-mt-dev).
+    * Build-depend on librsvg2-bin and Build-depend on netpbm, and
+      generate (not ship premade file) menu icon based on upstream
+      graphics: SVG → PNG → XPM.
+    * Drop Debian-local XDG desktop file: Upstream ships one now.
+    * Install symlinks in examples dir to demo_songs.
+    * Install PHP serverTools files as examples.
+    * Drop manpage symlink for hydrogenPlayer (not currently built).
+    * Bump Standards-Version to 3.8.4.
+    * Rewrite copyright file using draft DEP5 rev135 format.
+    * Add copyright header to debian/rules.
+    * Bump debhelper compat level and build-dependency to 6.
+    * Maintain build-dependencies with CDBS in debian/rules.
+ 
+  -- Jonas Smedegaard <dr at jones.dk>  Tue, 16 Feb 2010 06:26:18 +0100

** Summary changed:

- Hydrogen-0.9.4-1 sync request Sid (unstable) -> Lucid
+ Please sync hydrogen 0.9.4-1 from Debian unstable

** Changed in: hydrogen (Ubuntu)
       Status: New => Triaged

-- 
Please sync hydrogen 0.9.4-1 from Debian unstable
https://bugs.launchpad.net/bugs/495507
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list