[Bug 416907] Re: Please merge salliere 0.7.1-1 (universe) from Debian unstable (main)

Nicolas Van Wambeke nicolasvw at free.fr
Thu Sep 17 17:20:04 BST 2009


This is a debdiff with the above requested changes against debian
0.7.1-1

I was not able to reproduce the clean target breakage you display above,
for me it builds and cleans with no error.

** Attachment added: "salliere_0.7.1-1_0.7.1-1ubuntu1.debdiff"
   http://launchpadlibrarian.net/31974845/salliere_0.7.1-1_0.7.1-1ubuntu1.debdiff

** Description changed:

  Binary package hint: salliere
  
  Salliere 0.7-1 FTBFS in karmic because it is not compatible with libitext-java 2.x
  Debian already has 0.7.1-1 which builds fine in karmic with minor tweaking.
  
   * New Upstream release
    - patch to work on itext 2.x (Closes: #521967)
  
  The following changes have been needed in order for the package to build in Ubuntu:
-      * debian/rules:
-         - Changed call to jh_depends to only use it on package salliere
-      * debian/control:
-         - Modified gsalliere Depends: to salliere
+   * debian/rules:
+    - Changed call to jh_depends to only use it on package salliere
+   * debian/control:
+    - Dropped ${java:Depends} from gsalliere as jh_depends fails 
+      because of a dependency on salliere which is not installed.

-- 
Please merge salliere 0.7.1-1 (universe) from Debian unstable (main)
https://bugs.launchpad.net/bugs/416907
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list