[Bug 292253] Re: Gtranslator is too old in Ubuntu, please upgrade it

Emilio Pozuelo Monfort pochu at ubuntu.com
Wed Feb 11 16:26:15 GMT 2009

I'm not sure if it's wise to update to 1.9.4 or not, but since I don't use
gtranslator and you do, I'll leave that decision to you :-)

BTW, I've helped the Debian maintainer to package 1.9.4 in Debian, you may want
to sync the package instead. Here's the changelog entry:

gtranslator (1.9.4-1) experimental; urgency=low

  [ Jordi Mallach ]
  * New upstream development version. This branch is a complete rewrite
    that will eventually become 2.0.
    According to the new upstream, the following bugs should be fixed:
    - closes: #225324, Need to add space before every newline
    - closes: #254339, Search function doesn't handle non-ASCII content
    - closes: #256527, confuses "middle-dot" and "space" characters when
    - closes: #257184, Popup window opens UNDER the main window and is thus
                       not visible
    - closes: #258039, Search function alway searches all of comments,
                       english and translation
    - closes: #269779, Plural window lakes the OK button
    - closes: #277771, Search again for # does not work
    - closes: #278805, unused strings are always treated as utf8, and
    - closes: #295392, chosing Help->gtranslator website doesn't work
    - closes: #301608, To break lines with 80 columns for translation of
                       the templates.pot
    - closes: #313346, allow arbitrary translation teams
    - closes: #330958, Pressing Enter should validate the Goto dialog
    - closes: #345916, With long comment gtranslator window is wider than
    - closes: #353798, improper use of GError
    - closes: #355018, destroys plural msgstr structure in po file
    - closes: #357994, file incorrectly reported as already opened
  * Update Build-Depends to match requirements as declared by configure.ac.
  * Update menu section to "Applications".
  * Remove obsolete patches 01_pozilla_bash.patch,
    02_hebrew-translation-list.patch and
  * Don't remove src/defines.h, po/POTFILES and data/gtranslator.desktop,
    these workarounds shouldn't be needed anymore.
  * Update Build-Depends to libgdl-1-dev (>= 2.24.0), which is the first
    version not needing an undeclared libgnomeui-dev dependency, which
    broke gtranslator's build.
  * Add Build-Depends on libgdict-1.0-dev for the gdict plugin.
  * Add " -Wl,-O1 -Wl,-z,defs -Wl,--as-needed" to LDFLAGS to avoid
    extra dependencies as suggested by Loïc Minier.
  * Don't uupdate on the watch file.
  * Build-Depend on libapr1-dev, libaprutil1-dev, libneon27-gnutls-dev,
    libserf-0-0-dev and libsasl2-dev to get the Subversion plugin building.
  * Add --disable-scrollkeeper to DEB_CONFIGURE_EXTRA_FLAGS.
  * Add complete authorship and copyright details to the copyright file.
  * Add 01_manpage_hyphen.patch (also applied upstream) to fix a non-escaped
    hyphen in Gtranslator's manpage.

  [ Emilio Pozuelo Monfort ]
  * Standards-Version is 3.8.0, no changes needed.
  * Disable subversion plugin, as gtranslator is GPL and the subversion
    plugin links againt OpenSSL.
    + Remove subversion plugin's build dependencies.
  * Remove -Wl,-z,defs from LDFLAGS as that makes the build fail.
  * Exclude the private libraries from the dh_makeshlibs run.
  * Don't install the static libraries.

 -- Jordi Mallach <jordi at debian.org>  Wed, 11 Feb 2009 16:27:24 +0100

Gtranslator is too old in Ubuntu, please upgrade it
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.

More information about the Ubuntu-universe-sponsors mailing list