[Bug 501566] [NEW] Please sync fox1.6 1.6.36-2 (universe) from Debian unstable (main).

Launchpad Bug Tracker 501566 at bugs.launchpad.net
Wed Dec 30 07:27:15 GMT 2009


You have been subscribed to a public bug by Bhavani Shankar (bhavi):

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/fox1.6
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync fox1.6 1.6.36-2 (universe) from Debian unstable (main).


Explanation of the Ubuntu delta and why it can be dropped:

We can sync the package now as debian has incorporated all the ubuntu 
changes and has added section field in debian/control 

Changelog since current lucid version 1.6.25-1ubuntu1:

fox1.6 (1.6.36-2) unstable; urgency=low

  * configure.in: Conditionally link libfontconfig and libfreetype2 if
    directly accessed by FOX in current configuration (closes: #554399).
  * debian/control: Build-depend directly on these libraries.
  * debian/control: Add section: libs for source package 
    (closes: #561207, #561211).
  * Update to new source format 3.0 (quilt).
  * Relax build dependencies on OpenGL libraries to allow different
    implementations (closes: #461542).

 -- Torsten Landschoff <torsten at debian.org>  Sun, 20 Dec 2009 17:06:32
+0100

fox1.6 (1.6.36-1) unstable; urgency=low

  * New upstream release.
  * Updated config.sub, config.guess (closes: #401527, #537528). Not sure
    if those bugs were valid for fox1.6 anyway.
    Note that this is currently a hack, the whole autoconf generated code is
    updated by a quilt patch.
  * Use $(MAKE) instead of plain make in debian/rules to enable parallel
    builds.
  * Merge changes from NMU of 1.6.25-1.1 and my own upload which somehow did
    not make it to Subversion.
  * Add a debian/watch file.
  * Remove DH_COMPAT from debian/rules, set compatibility level 6 in
    debian/compat.
  * Generate autoconf, automake and libtoolize outputs during build instead
    of using a quilt patch for fixing the distributed generated files.
  * Fixes to comply with current Standards-Version:
    [ Policy 3.8.0 ]
    + Add debian/README.source with instructions how to add new patches.
    + debian/control: Add the Homepage field.
  * New patch fix_dup_widgets_html: Fixes doc/Makefile.am to not try
    installing widgets.html twice (breaks install target).
  * Depend on debhelper >= 6.

 -- Torsten Landschoff <torsten at debian.org>  Sat, 31 Oct 2009 19:59:32
+0100

fox1.6 (1.6.25-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix long-standing FTBFS on GNU/kFreeBSD (Closes: #414400):
     - Add autotools-dev to Build-Depends.
     - Copy /usr/share/misc/config.{guess,sub} before configure.
     - Delete config.{guess,sub} during clean to keep the diff clean.
  * Update Build-Depends to no longer list obsolete packages:
      - libcupsys2-dev → libcups2-dev
      - libglu1-xorg-dev → libglu1-mesa-dev
      - xlibmesa-gl-dev | libgl-dev → libgl1-mesa-dev
  * Ditto for Depends, and add ${shlibs:Depends} for the -dev package
    given that it contains the following binary: /usr/bin/reswrap-1.6,
    so that it gets a dependency on the libc.

 -- Cyril Brulebois <kibi at debian.org>  Sun, 19 Jul 2009 12:16:28 +0200


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFLOwBSL+KnYRaooWIRAud2AJ9bdtwhNM2RbPPYTOGhYwXCDIgNTwCfcajX
3+Jjhw+vgsWshWd19lRk10A=
=ax75
-----END PGP SIGNATURE-----

** Affects: fox1.6 (Ubuntu)
     Importance: Wishlist
         Status: New

-- 
Please sync fox1.6 1.6.36-2 (universe) from Debian unstable (main).
https://bugs.launchpad.net/bugs/501566
You received this bug notification because you are a member of Ubuntu Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list