[Bug 409034] Re: Please update uim to version 1.5.6 as it fixes a FTBFS

fabrice_sp coutadeurf at gmail.com
Mon Aug 10 06:19:08 BST 2009


Hi,

Here is the diff file with debian directory content.

The source tarball for 1.5.6 can be downloaded from
http://code.google.com/p/uim/

I've made the following changes in the packaging:
  * debian/control:
    - added Homepage tag
    - added watch file
    - bump Standards-Version to 3.8.2
    - changed build dependency on x-dev to x11proto-core-dev to avoid a lintian
      error (Debian bug #515522)
    - Added ${misc:Depends} to packages, to avoid several lintian warnings
    - Update build dependency on libgtk2.0-dev to delete the -1 revision and 
      fix this way another lintian warning
   * debian/uim-qt3.install: changed uim-chardict-qt.mo to uim.mo as upstream
     renamed it.
   * Added debian/README.source as this package uses dpatch to apply patches

Thanks,

Fabrice

** Summary changed:

- FTBFS because uim does not detect libgnomeui-2.0
+ Please update uim to version 1.5.6 as it fixes a FTBFS

** Description changed:

  Binary package hint: uim
  
  Hi,
  
  This package FTBFS because of missing gnome.h header.
  This is because this package is not aware of libgnomeui-2.0 package, and does not include the header and the lib.
  
- Forcing CFLAGS and LDFLAGS in debian/rules allow the package to compile
+ Updating to version 1.5.6 fixes this problem
  
  Cheers,
  Fabrice

** Attachment added: "uim_1.5.6-0ubuntu1.diff.gz"
   http://launchpadlibrarian.net/30097873/uim_1.5.6-0ubuntu1.diff.gz

-- 
Please update uim to version 1.5.6 as it fixes a FTBFS
https://bugs.launchpad.net/bugs/409034
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list