[Bug 298408] Re: Please merge darcs 2.1.0-1 (universe) from Debian unstable (main).

Launchpad Bug Tracker 298408 at bugs.launchpad.net
Sat Nov 22 14:05:06 GMT 2008


This bug was fixed in the package darcs - 2.1.0-1ubuntu1

---------------
darcs (2.1.0-1ubuntu1) jaunty; urgency=low

  * Merge with Debian unstable (LP: #298408), Ubuntu remaining changes:
   - debian/control:
    + Rebuild with ghc6 >= 6.8.2-6ubuntu2. Debian's -7 has the same fix,
      so this can be dropped when we next merge ghc6.
   - debian/rules:
    + Filter out -g from CFLAGS.

darcs (2.1.0-1) unstable; urgency=low

  * New upstream release.
    * Manpage patch included upstream, so remove patch support.
      It can be re-added later if necessary.
    * Warn user when remote host has darcs1 (Closes: #494109).
    * fix fix_filepath to work with --repodir (Closes: #458629).
    * darcs trackdown --set-scripts-executable (Closes: #462917).
  * Abolish darcs-server binary package
    (Closes: #498542, #489131, #339770, #486192).
  * Symlink identical HTML files (Closes: #491875).
  * Adopt "standard" copyright file format.
    Note that this patch only changes the format!  The
    copyright and license information still needs to be
    checked against current releases of Darcs; corrections
    will be a separate patch.
  * Correctly munge prerelease version strings.
  * control:
    * fix VCS URL.
    * enable DMs listed in Uploaders to upload directly.  For more
      information, see http://wiki.debian.org/Maintainers
    * refactor description field based on darcs homepage.
    * bump Standards-Version to 3.8.0.
      Add a Homepage field.
      Hard-wrap long fields (Uploads, Build-Depends) for readability.
    * Bump debhelper dependency so debian/clean works.

darcs (2.0.2-3) unstable; urgency=low

  * Bump ghc6 build-depends to >= 6.8.2-7 (Closes: #500563).

 -- Alessio Treglia <quadrispro at ubuntu.com>   Sat, 22 Nov 2008 10:48:12
+0100

** Changed in: darcs (Ubuntu)
       Status: Confirmed => Fix Released

-- 
Please merge darcs 2.1.0-1 (universe) from Debian unstable (main).
https://bugs.launchpad.net/bugs/298408
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list