[Bug 247389] Re: ecryptfs-utils build should not depend on libltspi or libopencryptoki-dev

Dustin Kirkland dustin.kirkland at gmail.com
Thu Jul 10 22:12:38 BST 2008


Patch updated to remove opencryptoki build dependency as well.  Not
needed either.

:-Dustin

** Summary changed:

- ecryptfs-utils build should not depend on libltspi
+ ecryptfs-utils build should not depend on libltspi or libopencryptoki-dev

** Description changed:

  Binary package hint: ecryptfs-utils
  
  The ecryptfs-utils build should not depend on libltspi.
  
  libltspi is a library provided by trousers for interfacing with on board
  TPM (trusted computing) hardware.
  
- The ecryptfs-utils debian/control file oddly requires libtspi-dev for
- the i386 architecture only.  This is not necessary.
+ libopencryptoki-dev is a library that deals with some cryptographic
+ accelerator hardware.
+ 
+ The ecryptfs-utils debian/control file oddly requires libtspi-dev and
+ libopencryptoki-dev for the i386 architecture only.  This is not
+ necessary.
  
  I'm filing an MIR for ecryptfs-utils and this unneeded build dependency
- would require bringing trousers and freetype1 into main.
+ would require bringing trousers, freetype1, and opencryptoki into main.
  
  I have emailed Debian about dropping (or softening) the build dependency
  as well, such that we can remain in sync on this package.
  
  
  :-Dustin

** Attachment added: "ecryptfs-utils.247389.debdiff"
   http://launchpadlibrarian.net/15940401/ecryptfs-utils.247389.debdiff

-- 
ecryptfs-utils build should not depend on libltspi or libopencryptoki-dev 
https://bugs.launchpad.net/bugs/247389
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list