[Bug 297169] Re: mozvoikko depends on iceweasel, should depend on firefox

Alexander Sack asac at jwsdot.com
Tue Dec 30 02:56:34 GMT 2008

On Tue, Dec 23, 2008 at 10:09:47AM -0000, John Vivirito wrote:
> On 12/23/2008 04:59 AM, Heikki Mäntysaari wrote:
> > I added iceweasel to the dependencies in my branch.
> > 
> > I'm attaching a new debdiff.
> > 
> > ** Attachment added: "mozvoikko_0.9.5-1ubuntu1.debdiff.4"
> >    http://launchpadlibrarian.net/20682398/mozvoikko_0.9.5-1ubuntu1.debdiff.4
> > 
> Thanks. Alexander im ok with this debdiff if it matters, its already got
> an ack from Mozilla team.

I dont know if i said different in the past, but if so I was wrong. I
would suggest to depend on the versioned packages, so you get an
implicit upper bound.

For instance: Depends: firefox-3.0, abrowser-3.0, iceweasel-3.0 (do
they have that?) ... problem is that currently you only know that you
are compatible with 3.0.* ... but not what will happen in future (so
no 3.*) ... can you adjust the depends accordingly?

 - Alexander

mozvoikko depends on iceweasel, should depend on firefox
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.

More information about the Ubuntu-universe-sponsors mailing list