[Bug 213494] Re: [Hardy] Glipper dies when desktop starting

Michael Nagel michael.nagel at devzero.de
Fri Aug 29 13:49:58 BST 2008


** Description changed:

  I use glipper all the time and I find it to be the clipboard application
  that has been missing from Linux desktops for the longest time. In the
  recent Hardy development I find that glipper dies when the desktop
  starts. I receive the following message in an error dialog window:
  
  The panel encountered a problem while loading OAFIID:Glipper....
  
  The  is asks if I want to remove glipper  from the panel. I find this
  very frustrating. What is more frustrating is that once the desktop is
  up and running I can then install the glipper applet back on the panel
  and it works properly. I have only installed this as an applet and I
  have never tried setting up a custom launcher.
  
  DISTRIB_ID=Ubuntu
  DISTRIB_RELEASE=8.04
  DISTRIB_CODENAME=hardy
  DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
  
  glipper:
    Installed: 1.0-1
    Candidate: 1.0-1
    Version table:
   *** 1.0-1 0
          500 http://us.archive.ubuntu.com hardy/universe Packages
          100 /var/lib/dpkg/status
  
  
  Traceback originally from Bug #222846:
  
  ProblemType: Crash
  Architecture: i386
  Date: Sun Apr 27 03:59:12 2008
  DistroRelease: Ubuntu 8.04
  ExecutablePath: /usr/lib/glipper/glipper
  InterpreterPath: /usr/bin/python2.5
  Package: glipper 1.0-1ubuntu1
  PackageArchitecture: i386
  ProcCmdline: python /usr/lib/glipper/glipper
  --oaf-activate-iid=OAFIID:Glipper_Factory --oaf-ior-fd=33
  ProcEnviron:
   LANG=en_US.UTF-8
  
  PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
   SHELL=/bin/bash
  PythonArgs: ['/usr/lib/glipper/glipper',
  '--oaf-activate-iid=OAFIID:Glipper_Factory', '--oaf-ior-fd=33']
  SourcePackage: glipper
  Title: glipper crashed with ValueError in load()
  Uname: Linux 2.6.24-16-386 i686
  UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev
  sambashare scanner video
  
  
  Traceback (most recent call last):
    File "/usr/lib/glipper/glipper", line 53, in applet_factory
      glipper.Applet.Applet(applet)
    File "/var/lib/python-support/python2.5/glipper/Applet.py", line 50, in __init__
      get_glipper_history().load()
    File "/var/lib/python-support/python2.5/glipper/History.py", line 89, in load
      self.history.append(file.read(int(length)))
  ValueError: invalid literal for int() with base 10: '\x14\x0b'
  
  
  
- Possible work around from Bug #205507:
+ Proposed Workaround:
+ So what to do: Look up Glipper and add a wait statement:
  
- Glipper has moved from being an app to a applet (which is confusing
- enough), however it crashed when I tried to add it to the panel, unless
- I deleted the ~/.glipper directory first.
+ sudo gedit /usr/lib/glipper/glipper
+ 
+ Make sure the code in the beginning looks like this:
+ 
+ #!/usr/bin/env python
+ 
+ # Glipper - Clipboardmanager for GNOME
+ # Copyright (C) 2007 Glipper Team
+ # bla bla bla
+ # License along with this library; if not, write to the
+ # Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ # Boston, MA 02111-1307, USA.
+ #
+ 
+ import time # <-- This line is new
+ time.sleep(8) # <-- This line is new. Change the 8 to for instance 30 if it did not help
+ 
+ import gobject
+ gobject.threads_init()
+ 
+ import gtk, gnomeapplet, gnome
+ import getopt, sys
+ from os.path import *
+ 
+ 
+ 
+ Proposed Solution(? needs to be verified):
+ Crashing in Intrepid too. It needs to be rebiult againsta libffi5 instead of libffi4

-- 
[Hardy] Glipper dies when desktop starting
https://bugs.launchpad.net/bugs/213494
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list