[Bug 256551] [NEW] Please sync erlang 1:12.b.3-dfsg-4 (universe) from Debian unstable (main).

Bhavani Shankar right2bhavi at gmail.com
Sun Aug 10 08:37:15 BST 2008


Public bug reported:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/erlang
 status new
 importance wishlist
 subscribe ubuntu-universe-sponsors

Please sync erlang 1:12.b.3-dfsg-4 (universe) from Debian unstable
(main).


Explanation of the Ubuntu delta and why it can be dropped:

Debian has fixed erlang-depends script to add additional dependency and 
has refreshed and fixed several patches while incorporating other 
changes. So ubuntu changes can be dropped.

Changelog since current intrepid version 1:12.b.3-dfsg-1ubuntu1:

erlang (1:12.b.3-dfsg-4) unstable; urgency=low

  * Fixed erlang-depends script to add optional dependency on erlang-base-hipe
    to ${erlang-base:Depends} substvar for all architecture-independent
    packages. Otherwise building them on different architectures will lead to
    different dependencies.
  * Added Vcs-Svn and Vcs-Browser headers to debian/control.
  * Removed package libgd2-xpm-dev from build dependencies which is not
    necessary anymore.
  * Added a patch which fixes detaching of erlang process from a controlling
    terminal (closes: #463538).

 -- Sergei Golovan <sgolovan at debian.org>  Sun, 20 Jul 2008 08:12:37
+0400

erlang (1:12.b.3-dfsg-3) unstable; urgency=low

  * Fixed patches to reenable building erlang regexp driver for common_test
    application on hurd-i386 architecture.
  * Refreshed patches and made their description more clear.
  * Made dependencies of architecture-independent packages erlang,
    erlang-examples and erlang-src the same regardless of whether they are
    built on HiPE-enabled architecture or not.

 -- Sergei Golovan <sgolovan at debian.org>  Mon, 14 Jul 2008 09:18:15
+0400

erlang (1:12.b.3-dfsg-2) unstable; urgency=low

  * Adjusted erlang-base-hipe package priority to extra as it conflicts with
    erlang-base.
  * Added several substitution variables in debian/control to remove
    dependencies on hurd and erlang-base-hipe for architectures where these
    packages don't exist.
  * Changed erlang-depends script to generate dependency on erlang-base-hipe
    only for architectures where HiPE is available.
  * Enabled kernel poll for kfreebsd-i386 and kfreebsd-amd64 architectures.
  * Explicitly specified host and build architecture to erlang configure
    script.
  * Typer application requires dialyzer to work, so moved it to erlang-x11
    package.
  * Added a typer manpage based on typer --help output.

 -- Sergei Golovan <sgolovan at debian.org>  Fri, 11 Jul 2008 22:53:54
+0400


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFInpqpL+KnYRaooWIRAt4oAKCTthq6CZo1azV/3u7dyPYJha8c8wCgmCzf
OmUnCgabd9YHan5YUHJk+gc=
=mKqO
-----END PGP SIGNATURE-----

** Affects: erlang (Ubuntu)
     Importance: Wishlist
         Status: New

-- 
Please sync erlang 1:12.b.3-dfsg-4 (universe) from Debian unstable (main).
https://bugs.launchpad.net/bugs/256551
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list