[Bug 139007] Re: [UVFe] Import firebird2.0 2.0.3.12981.ds1-1 from Debian unstable (main)

Luca Falavigna dktrkranz at ubuntu.com
Fri Sep 14 14:10:15 BST 2007


firebird2.0 (2.0.3.12981.ds1-1ubuntu1) gutsy; urgency=low

  * Resync with Debian unstable after UVFe approval in LP: #139007
  * Enable port-ia64.patch to avoid FTBFS on ia64
  * Update Maintainer field in debian/control

firebird2.0 (2.0.3.12981.ds1-1) unstable; urgency=medium

  * New upstream relese-candidate
  * Contains fixes for the following security issues: CVE-2007-3527,
    CVE-2007-4664, CVE-2007-4665, CVE-2007-4666, CVE-2007-4667, CVE-2007-4668,
    CVE-2007-4669.
    (Closes: #441405) -- Several Firebird vulnerabilities discovered
  * Refreshed patches
    cvs-client-crash-on-remote-shutdown.patch
    no-rpath.patch
    link-as-needed
    fix-os-detection.patch
    inet-trust-localhost.patch
    create-run-dir.patch
    use-debian-icu.patch
    use-debian-editline.patch
    cvs-powerpc-double-define.patch
  * Dropped patches not needed any more
    + link-with-g++.patch -- upstream reorg
    + cvs-common_classes_alloc.cpp-unaligned.patch -- included in the
      release
    + cvs-jrd.cpp-crash-on-srervices-and-conventional-api-usage.patch --
      included in the release
    + cvs-sparc-jrd_sort.patch -- included in the release
    + cvs-remote-alignment.patch -- included in the release
  * autoboot.patch -- re-generated
  * Updated debian/get-orig-source.sh
    + use pre-release upstream download area
  * Applied patch to Hungarian translation from Tamas TEVESZ
  * debian/make_packages.sh - deduce upstream version from debian/changelog to
    avoid the need of manually changing a variable after each new upstream
    release
  * Updated debian/watch with new pre-release URLs; more version mangling
  * Dropped unused lintian overrides
  * Drop libgds.so compatibility symlink (upstream dropped it after 1.5)

firebird2.0 (2.0.1.12855.ds1-9) unstable; urgency=low

  * Build-Depend on libicu36-dev (from libicu34-dev)
  * [clean-after-build.sh] do not remove build_no.h

firebird2.0 (2.0.1.12855.ds1-8) unstable; urgency=low

  * Detect missing debconf in .postrm/purge and don't remove any
    password/security/database files. Spit messages about that.
    Closes: #431852 depends on non-essential package debconf in postrm
    Thanks to Michael Ablassmeier

 -- Luca Falavigna <dktrkranz at ubuntu.com>   Wed, 12 Sep 2007 21:33:14
+0200

** Changed in: firebird2.0 (Ubuntu)
       Status: Confirmed => Fix Released

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-3527

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4664

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4665

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4666

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4667

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4668

** CVE added: http://www.cve.mitre.org/cgi-
bin/cvename.cgi?name=2007-4669

-- 
[UVFe] Import firebird2.0 2.0.3.12981.ds1-1 from Debian unstable (main)
https://bugs.launchpad.net/bugs/139007
You received this bug notification because you are a member of Ubuntu
Sponsors for universe, which is a direct subscriber.



More information about the Ubuntu-universe-sponsors mailing list