2008/4/29 Dianne Reuby &lt;<a href="mailto:pramclub@yahoo.co.uk">pramclub@yahoo.co.uk</a>&gt;:<br><div class="gmail_quote"><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
I&#39;ve tried that, problem is it doesn&#39;t &quot;stick&quot; - when I close the<br>
Options, and reload, I still get the message, and the options shows JRE<br>
as unselected again.<br>
</blockquote><div><br>I have had this exact issue and I managed to solve it by deleting the actual config file from the OpenOffice application directory in $HOME/.openoffice.org2/user/config/javasettings_Linux_x86.xml <br>
<br>The file is recreated on OpenOffice restart and contains the correct path based on your next choice, it also remembers it in the OpenOffice dialogue. I&#39;m guessing (for whatever reason) the file is locked and it refuses to change it.<br>
</div><div><br>Just in case I&#39;m wrong, please create a back up of that config file (or rename it) before attempting this. Ensure you shut down all running instances of OpenOffice before you delete it as well.<br><br>Hope that helps, do post if you discover success or problems<br>
<br>Tyrrell<br>&nbsp;</div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;"><br>
Dianne<br>
<br>
<br>
On Tue, 2008-04-29 at 21:59 +0100, David Jones wrote:<br>
&gt; <br>
<div><div></div><div class="Wj3C7c">&gt; &nbsp; &nbsp; &nbsp; &nbsp; I had the same error message today after upgrading.<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; To solve it, from within OpenOffice Writer (Possibly the others<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; as well), I went to Tools -&gt; Options -&gt; Java<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; After a few seconds, a screen with Sun Microsystems Inc.1.6.0_06<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; and<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Sun Microsystems Inc 1.6.0 with accessibility comes up.<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; I ticked the box for version 1.6.0_06, restarted OpenOffice<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Writer and the error message went away.<br>
&gt;<br>
&gt; &nbsp; &nbsp; &nbsp; &nbsp; Hope that helps<br>
&gt;<br>
&gt;<br>
&gt; On Tue, 2008-04-29 at 21:35 +0100, Dianne Reuby wrote:<br>
&gt; &gt; Updated to Hardy yesterday. I&#39;m getting JRE errors in Open Office,<br>
&gt; &gt;<br>
&gt; &gt; &quot;OpenOffice.org requires a Java runtime enviornment (JRE) to perform the<br>
&gt; &gt; task. The selected JRE is defective. Please select another version&quot;<br>
&gt; &gt;<br>
&gt; &gt; I already have openoffice.org-java-common installed, version 1:2.4 in<br>
&gt; &gt; usr/lib/openoffice (which is the solution given in the forums).<br>
&gt; &gt;<br>
&gt; &gt; OO options shows Sun Java 1.6.0_06 , in usr/lib/jvm<br>
&gt; &gt;<br>
&gt; &gt; So which should I be using? I remember when I first switched to Ubuntu,<br>
&gt; &gt; I was using Dapper, and had to uninstall the Ubuntu JRE and install the<br>
&gt; &gt; Sun JRE. Do I need to do this again?<br>
&gt; &gt;<br>
&gt; &gt; One day I&#39;ll understand it all ....<br>
&gt; &gt;<br>
&gt; &gt; TIA<br>
&gt; &gt; Dianne<br>
&gt; &gt;<br>
&gt; &gt;<br>
&gt;<br>
&gt;<br>
<br>
<br>
--<br>
<a href="mailto:ubuntu-uk@lists.ubuntu.com">ubuntu-uk@lists.ubuntu.com</a><br>
<a href="https://lists.ubuntu.com/mailman/listinfo/ubuntu-uk" target="_blank">https://lists.ubuntu.com/mailman/listinfo/ubuntu-uk</a><br>
<a href="https://wiki.ubuntu.org/UKTeam/" target="_blank">https://wiki.ubuntu.org/UKTeam/</a><br>
</div></div></blockquote></div><br>