[ubuntu-uk] Help required with a wi-fi networking problem

Barry Titterton titterton.barry at gmail.com
Thu Oct 11 22:18:05 UTC 2012

On 11/10/12 14:08, A wrote:
> On 11/10/12 13:49, Barry Titterton wrote:
>> On 11/10/12 12:57, A wrote:
>>> If you've enabled precise-proposed (or precise-backports etc) then you
>>> get access to some newer, developmental bugfix packages etc
>>> If the fixed wpasupplicant package is then uploaded to the main
>>> 'precise' repository, which is enabled by default, then all's well. I
>>> like to keep all the precise-* repos enabled because it gives you access
>>> to fixes and new features that have trickled through from upstream,
>>> without having to jump to the next release(s).
>>> Short answer: i'd keep precise-proposed access enabled.
>>> Happy to help get your wife's connection sorted. I'm at university
>>> myself and new linux users often have to sink or swim with things like
>>> this: take this life jacket ;)
>> Thanks for the quick reply, and the reassurance.
>> Have you had similar problems connecting to the wi-fi at your university?
>> Durham has close links with Microsoft, and the IT department only
>> offers help for problems with Microsoft software products. Their
>> support for Macs is minimal and grudging, there is no general help for
>> linux except for specific help for the high performance computing
>> facility. There is a little linux help if you are from another
>> university and trying to access the Eduroam system. My request for
>> help sent to the IT Help Desk has gone unanswered.
>> I had hoped to do some gentle linux evangelizing among the unbelievers
>> but this rather public problem has got things off to a bad start. I
>> shall have to be patient.
>> Barry T
> Well, i did have some problems at first trying to connect to the
> wireless network on campus, but then i had a quick look and found
> there's a certificate to use and after 5 minutes of messing around, i
> figured it out and it works wonderfully.
> I know - it's a bit of a mess, the current state of so called 'IT
> expertise' - why, just this week my friend went to see the IT department
> on campus about recovering some deleted files from linux and they didn't
> have a clue. Problem solved after using 'photorec' and 'scalpel'
> ourselves. It's seems like the prerequisite for being an 'IT
> professional' is knowing how to click a few buttons on microsoft office
> - everyone working on IT support should be familiar with at least 1
> linux distro, really. The operating systems are free, and if you're
> trying to help people for a living, there will be people who use this -
> it costs nothing but time to learn a few commands.
> They think everyone uses windows and the odd (rich) person uses a mac,
> but the linux users are fringe rebels lol I would bet heavily that you
> either don't get a reply, or it isn't any use when it arrives. They're
> just not clued in: what you need is another linux user from the online
> community or nearby.
> I think UK universities (can't say what state other country's are in)
> need to expand their knowledge on linux because often times the solution
> is just 1 tiny command instead of a 2 page list of clicking instructions.
> As far as your problem goes, a bug will come to light every now and then
> when new code is added or old code is reviewed, and then it gets fixed.
> I had a look at your link to the bug on launchpad and it seems to affect
> the openssl package as well. Once the packages are in the repositories
> and you've got those repos enabled, update and upgrade and try
> connecting again. Keep us apprised of the details and we'll have it
> sorted in no time - it's usually just a case of messing around with the
> configurations (and it only ever gets complicated because IT departments
> are NEVER specific enough about the details, whereas e.g. on your own
> home network, you call the shots and you have access to specific settings.)
> Try not to get discouraged because prevailing over these tiny obstacles
> does pay off in the long run.
Success! The fix from precise-proposed worked perfectly. My wife will 
give it a full road test next week.

I got a reply from the Durham uni' IT help desk. It said that they do 
not support linux and suggested using the Win7 settings as a clue. The 
irony being that the Win7 settings do not work for windows machines 
either, an IT savvy student managed to get the windows machines working 
despite the IT department. I shall have to offer my services to the IT 
help desk to write a linux guide for them. I have also made contact with 
the local LUG which should be a much better source for tech help.

I shall also have to put a comment on the bug discussion thread, if I 
can remember my log on details.

Barry T

More information about the ubuntu-uk mailing list