[ubuntu-uk] Problems with OpenGl and libGL

David King linuxman at avoura.com
Sat Dec 15 19:55:31 UTC 2012


I am running Ubuntu Studio 12.04 64-bit version.

I have OpenGL and libGL stuff installed, but recently things that 
require it no longer run and I get an error message when trying to run 
from the command line like this:

    cairo-dock: error while loading shared libraries: libGL.so.1: cannot
    open shared object file: No such file or directory



I have libgl1-mesa-glx installed, which provides libGL.so.1

I have Codeweavers Crossover 12.0 installed as well, and this has a 
diagnostics program cxdiag which gives the following output:

    ~$ /opt/cxoffice/bin/cxdiag
    [MissingLibGlu]
    "Level"="Recommend"
    "Title"="Missing 32bit libGLU.so.1 library"
    "Description"="This may be needed by some games or CAD applications."

    [MissingLibGsm]
    "Level"="Suggest"
    "Title"="Missing 32bit libgsm.so.1 library"
    "Description"="Lets Windows applications use the GSM codec for audio
    compression and decompression."

    [MissingLibNss_mdns]
    "Level"="Require"
    "Title"="Missing 32bit libnss_mdns.so.2 library"
    "Description"="This library is needed for network and Internet
    access. Installing it is strongly recommended."

    [Properties]
    "display.depth"="24"

    [MissingLibGL]
    "Level"="Recommend"
    "Title"="Missing 32bit libGL.so.1 library"
    "Description"="Provides hardware-accelerated Direct3D and OpenGL
    support. This is used for games, but also for CAD applications."

    [OpenglNotWorking]
    "Level"="Recommend"
    "Title"="OpenGL does not work"
    "Description"="OpenGL did not work in our simple tests. This means
    OpenGL and DirectX applications, including most games, will likely
    not work. Other applications should be unaffected."




I already installed the 32-bit libraries required by Crossover. Although 
if it still needs the ones listed above, then how can I install those? 
i.e. instead of the 64-bit versions, what command do use to install a 
32-bit version? I tried sudo apt-get install libgl1-mesa-glx:386 and 
similar but nothing got installed as it could not find the package.

Things like Cairo Dock which was the first thing I noticed had failed to 
run yesterday needs OpenGL libraries and so will not run, although I do 
not know if it is 32- or 64-bit.

Before that everything worked fine. So I do not know what happened to 
break the system and OpenGL.

The only thing I can think of is I had a small problem with Crossover 
running Photoshop, and I had to install the libjpeg (or similar) 
library, 32-bit, to get that working. And I updated Crossover from 11.3 
to 12.0.


Any ideas on how to get OpenGL working again?


David K




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20121215/3086d2d3/attachment.html>


More information about the ubuntu-uk mailing list