[ubuntu-uk] ubuntu-uk Digest, Vol 78, Issue 28

David Goldsbrough daveg at boavon.plus.com
Mon Oct 17 22:58:16 UTC 2011

Thanks Colin - I'll see if I can give the time to try your suggestion
- but all those screws and stuff tends to put me off :)  Always been a
software man rather than hardware.  One theory I had from some of the
research was it that it was something to do with ACPI.  Other oldish
Toshibas have had similar fates.  Its only a guess, but I suspect
"suspension" writes something to the disk that Toshiba BIOS/boot
relies upon not being messed with -- so the boot bits and the BIOS
become corrupt.  I suspect both need fixing.  Oddly, or not, the disk
refuses to be seen by a windose vista machine
Dave G

> Date: Mon, 17 Oct 2011 21:08:02 +0100
> From: Colin Law <clanlaw at googlemail.com>
> To: UK Ubuntu Talk <ubuntu-uk at lists.ubuntu.com>
> Subject: Re: [ubuntu-uk] Toshiba Portege P4010 - BIOS Bad Block 3
> Message-ID:
>        <CAL=0gLuthJAwnrD6q0b6QpyYrgGGOoxT4NufyVXHF6uRkuQO9w at mail.gmail.com>
> Content-Type: text/plain; charset=UTF-8
> On 17 October 2011 17:44, David Goldsbrough <daveg at boavon.plus.com> wrote:
>> Hi,
>> Up until Friday I was happily runnng Ubuntu on subject machine. ?It
>> has never managed to do a restore before, and I have always shutdown
>> and re-booted whenever softaware updates requested it.
>> I have never tried ever to suspend it or hibernate it, due to bad
>> attitude on my part as I regard this function as "fancy-dan stuff". ?I
>> also suspected it would never be able to cope on the basis that if
>> "restart" never worked then suspend or hibernate never would either.
>> On Friday though my "wisdom" got the better of me and I tried to
>> suspend it. ?Boy, did it sulk. ?It just went dead! ?Any attempts to
>> re-boot it results in an error message "BIOS(Block3) is damaged! (call
>> user serviceman.) ?Serviceman: Place maintenance disk in drive and
>> press any key when ready."
>> I have spent the weekend on and off researching the net and trying a
>> few things. ?It would seem that I am unable to access the BIOS at boot
>> time. ?Pressing F2 is the normal access method but I have tried the
>> ESC key and the left-shift key. ?The DVD drive is not accessible and
>> there is no floppy drive. ?I do have a usb read-only floppy drive
>> available but I suspect the usb ports are not operable either.
>> I did see some reference to getting a boot floppy and altering some of
>> the bytes with a hex editor which somehow fooled the BIOS and then
>> allowed the BIOS to be flashed. ?I never pursued this solution as I
>> could not think (or did not have the means) of achieving. ?I also had
>> some doubt whether it would work. ?I could find nobody who had
>> actually really fully solved the BIOS error.
>> The machine cost me less than ?50 some years ago, but I loved it so
>> much! ?It was my Ubuntu/linux learning platform. ?Is it time for the
>> scrap heap?
> You could try taking the BIOS battery out for a minute or so (assuming
> it has a BIOS battery - it will be a coin type cell.  that should
> force the battery backed ram back to default values, if it is that
> that has got corrupted.  It may be worth shorting the battery contacts
> on the board with a screwdriver after removing the battery (the
> contacts on the board, not the battery itself), that will ensure the
> circuit is fully discharged.  You should get a message saying the ram
> has been defaulted when you switch on again.
> Otherwise I suppose it could be the BIOS flash itself corrupted, but
> how that could happen as a result of suspending is beyond me.
> Colin

More information about the ubuntu-uk mailing list