[ubuntu-uk] Toshiba Portege P4010 - BIOS Bad Block 3

Colin Law clanlaw at googlemail.com
Mon Oct 17 20:08:02 UTC 2011

On 17 October 2011 17:44, David Goldsbrough <daveg at boavon.plus.com> wrote:
> Hi,
> Up until Friday I was happily runnng Ubuntu on subject machine.  It
> has never managed to do a restore before, and I have always shutdown
> and re-booted whenever softaware updates requested it.
> I have never tried ever to suspend it or hibernate it, due to bad
> attitude on my part as I regard this function as "fancy-dan stuff".  I
> also suspected it would never be able to cope on the basis that if
> "restart" never worked then suspend or hibernate never would either.
> On Friday though my "wisdom" got the better of me and I tried to
> suspend it.  Boy, did it sulk.  It just went dead!  Any attempts to
> re-boot it results in an error message "BIOS(Block3) is damaged! (call
> user serviceman.)  Serviceman: Place maintenance disk in drive and
> press any key when ready."
> I have spent the weekend on and off researching the net and trying a
> few things.  It would seem that I am unable to access the BIOS at boot
> time.  Pressing F2 is the normal access method but I have tried the
> ESC key and the left-shift key.  The DVD drive is not accessible and
> there is no floppy drive.  I do have a usb read-only floppy drive
> available but I suspect the usb ports are not operable either.
> I did see some reference to getting a boot floppy and altering some of
> the bytes with a hex editor which somehow fooled the BIOS and then
> allowed the BIOS to be flashed.  I never pursued this solution as I
> could not think (or did not have the means) of achieving.  I also had
> some doubt whether it would work.  I could find nobody who had
> actually really fully solved the BIOS error.
> The machine cost me less than £50 some years ago, but I loved it so
> much!  It was my Ubuntu/linux learning platform.  Is it time for the
> scrap heap?

You could try taking the BIOS battery out for a minute or so (assuming
it has a BIOS battery - it will be a coin type cell.  that should
force the battery backed ram back to default values, if it is that
that has got corrupted.  It may be worth shorting the battery contacts
on the board with a screwdriver after removing the battery (the
contacts on the board, not the battery itself), that will ensure the
circuit is fully discharged.  You should get a message saying the ram
has been defaulted when you switch on again.

Otherwise I suppose it could be the BIOS flash itself corrupted, but
how that could happen as a result of suspending is beyond me.



More information about the ubuntu-uk mailing list