[ubuntu-uk] SATA drive problem .....

Barry Drake bdrake at crosswire.org
Fri Mar 18 12:20:44 UTC 2011

Hi there ......

I'm really scratching my head over this one.  My wife's computer has a
ALiveNF6P-VSTA motherboard.  This has one IDE connector and four SATA
ports.  It was running Windows 2000 on a SATA drive, so I installed a
second SATA drive (250 GiB) and put Ubuntu 10.04 on it.  I also
installed a 160 GiB IDE drive for backups and all was fine.

Last week, the IDE drive gave a SMART report that it was getting flaky
so I replaced it with a 500 GiB Hitachi SATA drive.  Problems!  Could
not copy more than 167.9 MB of data (by any means)  After that, the
partition (ext4) became read only until I rebooted!  I tried
re-partitioning and re-formatting and the drive appeared to die.  A
Hitachi boot disk with a diagnostic/repair tool told be that the boot
sector had an irrecoverable mechanical error.

As a last resort, I popped the drive into my computer, and it
re-formatted perfectly and showed no SMART errors.  I tried a 160 GiB WD
drive in my wife's computer.  EXACTLY the same problem occurs.  I've now
re-formatted it to NTFS and tried booting into the Windows 2000 disk.
There is no problem copying files to the WD disk from Windows. But the
problem is identical from Ubuntu.

I've tried swapping the disks into different SATA slots and I've tried
various things in the BIOS.  The only clue here is that the Mobo manual
tells me: "LBA/Large Mode - Use this item to select the LBA/Large mode
for a hard disk > 512 MB under DOS and Windows; for Netware and UNIX
user, select [Disabled] to disable the LBA/Large mode."

I've tried this on the WD drive and it makes no difference.  I tried it
on the Ubuntu drive, but it causes Grub failure and brings up the Grub
rescue prompt.  I could re-install with the LBA/Large mode turned off,
but it's going to be hard for me to do a backup first ....  I think I'd
have to re-install an IDE drive to do it.

This entire saga doesn't make any sense at all to me.  Any thoughts?  I
have no problem at all with either of the above SATA drives in my own
computer which also has three SATA drives installed - and the LBA/Large
mode is set to 'auto' on that one.

Kind regards,		Barry.

Barry Drake is a member of the the Ubuntu Advertising team.

More information about the ubuntu-uk mailing list