[ubuntu-uk] LDAP server Invalid credentials

Jacob Mansfield cyberjacob at gmail.com
Wed Jan 19 22:07:46 UTC 2011

On 17/01/11 09:00, Byte Soup wrote:
> Hi Jacob,
> I have a small amount of experience using Sun's LDAP, see my comment below
> -Mark
> On 14 January 2011 22:31, Jacob Mansfield <cyberjacob at gmail.com
> <mailto:cyberjacob at gmail.com>> wrote:
>     I have been trying to set up an LDAP server for some time now.
>     when I finally found an up-to-date tutorial at
>     http://www.zarafa.com/wiki/index.php/Zarafa_LDAP_cn_config_How_To
>     the first step of this has worked fine however when running the
>     command
>     ldapadd -x -D cn=admin,dc=cyberkingsolutions,dc=co,dc=up -W -f base.ldif
> try using the -w switch followed by a password. For example this is a
> command I used to import a schema
> |./ldapmodify -v -c -a -e /opt/schema_rejects -h localhost -p 390 -D
> cn=dmanager -w dmanager -f </path/to/schema/ldif-file>|
>     I am prompted for a password. I enter the password I have used at
>     all other points tn the tut and are met with a fail message:
>     ldap_bind: Invalid credentials (49) when not entering a password
>     at the prompt (just hitting return) I get ldap_bind: server is
>     unwilling to perform (53) additional info: unauthenticated bind
>     (DN with no password) disallowed.
>     please help me get LDAP working,
>     and thanks in advance (I know all of you awsome guys (and gals (or
>     gales according to auto-correct)) will find the problem and help
>     me fix it)
>     -- 
>     Jacob Mansfield
>     Programmer
>     import disclaimer from email
>     --
>     ubuntu-uk at lists.ubuntu.com <mailto:ubuntu-uk at lists.ubuntu.com>
>     https://lists.ubuntu.com/mailman/listinfo/ubuntu-uk
>     https://wiki.ubuntu.com/UKTeam/
I ran:
root at megacat:~# ldapmodify -v -c -a -x -D cn=admin -w MyPassWord -f
and got:
ldap_initialise( <DEFAULT> )
ldap_bind: Invalid Credentials (49)
so it didn't work, unless I got it wrong

Jacob Mansfield

import disclaimer from email

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20110119/151a98d4/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 554 bytes
Desc: OpenPGP digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20110119/151a98d4/attachment-0001.pgp>

More information about the ubuntu-uk mailing list