[ubuntu-uk] Problem with Username and password for Synaptic

Alan Bell alan.bell at libertus.co.uk
Fri Dec 9 16:33:57 UTC 2011


On 09/12/11 15:33, scoundrel50a wrote:
> have tried a couple of times on ubuntu-uk but not got anywhere there, 
> so thought I would try here. I had a problem with a desktop on my 
> laptop, it disappeared after an update. I created a new username and 
> password, which I can use to log in, but when I go to look in 
> Synaptic, it calls for just the old log in details, and I can dont 
> know why, would anybody have any ideas?
>
> John
>
I think you have been and gone a couple of times before your problem was 
solved, I don't know if you are on a dialup connection, but generally if 
you stick around for a few hours you will give people more of a chance 
to see your problem and respond to it. First time you were on we 
discovered that you didn't have the users and groups tool installed, 
after you left I commented that perhaps you don't have the 
ubuntu-desktop package installed, which would have pulled this and other 
items in.
So the situation is that you installed ubuntu with one account, then 
created a second account which was not initially an administrator 
account, but now is I think in the right groups. When you perform an 
action that requires sudo access your machine prompts you for the 
username and password of the primary user. This is quite similar to my 
kid's computers where they don't have admin accounts, if they go to 
install something from software centre (why are you using synaptic 
rather than software centre? Is it a synaptic specific issue or does for 
example the unlock button on the users and groups tool prompt for the 
primary user password too?) then I have to put in my password for them 
because they are not in the sudoers file (or in the admin group which is).
I think the first time you came on IRC we got you set up with the right 
groups from the command line and got you to install the users and groups 
app. I would suggest sudo apt-get install ubuntu-desktop to make sure 
there is nothing else missing that is critical. Can you in fact run 
things with sudo under your new username?

Alan.

-- 
Libertus Solutions http://libertus.co.uk




More information about the ubuntu-uk mailing list