[ubuntu-uk] Borked my Mac installing Ubuntu 11.04, now blackscreens & beeps on restart then takes exactly 4 attempts to boot

Matthew Daubney matt at daubers.co.uk
Sat Apr 30 14:58:57 UTC 2011


On 30 April 2011 01:55, doug livesey <biot023 at gmail.com> wrote:

> So guess who broke his Mac trying to install the latest Ubuntu?
> Every now & then, I think I'm more of a geek than I really am, and try to
> do something to make myself feel hardcore, but that ends up just being plain
> humbling!
> There follows a cut & paste from a post I left on the Ubuntu forums, but
> basically I've been stung by over-ambitious early-adopter's syndrome (which
> may or may not be a real term, I've been trying to fix my computer for the
> last 2 days straight & can't remember how humans actually talk to each
> other).
> Anyway, in the hope that some local talent may see this & know what's going
> wrong ...
>
> Hi -- I've tried to install 11.04 on my Macbook Pro (5,4) today.
> I had two drives in the machine, an SSD as my main drive, and an HD.
> I installed rEFIt before attempting to install Ubuntu.
> I moved my Snow Leopard install to the secondary HD & made sure I could
> boot to it.
> Then, I used the live CD & gparted to clear the 1st drive (the SSD), create
> the swap space, create the Ubuntu partition, and launch the install, where I
> used what I had just created on the SSD.
> The install completed okay (but with no option to select where the GRUB
> installer went, like some tutorials tell you to look out for).
> This seemed to go okay, so I went to restart at the end of the install, but
> the machine didn't come back up.
> Instead, the power came on & I could hear the drives, but the screen stayed
> black, the battery light flashed a load of times really quickly (too quickly
> to count, but at least 10 times), and then the machine let out 1 long beep
> and stayed on the black screen.
> I forced it to power down & tried again, and just got a black screen, the
> battery light shining steadily, and no beep.
> I forced it to power down again, and got the same, then again, and got the
> same, and then a 4th time, which actually allowed me to boot.
> And this has been the pattern since then. I shut down, and my first attempt
> to restart gets me the flashing light and the beep, with the black screen. I
> try 3 more times to power down and restart, and just get the black screen.
> Then, *every* time on the 4th time, I'm allowed to boot.
> The same routine will be gone through the next time I power down and try to
> restart.
> I've tried totally clearing the disk in gparted, restoring the OSX install
> from TimeMachine, everything I could think of, but all to no avail.
> Finally, thinking that maybe the OSX install I had safe on the secondary HD
> might still be okay (looking at it in gparted showed an EFI boot section &
> everything), I opened up my MBP, swapped the drives around so that the HD is
> now the main drive, and the SSD the secondary, and renamed the drives so
> that the primary HD is now called 'Macintosh HD' and is first in the list of
> drives that appear when I manage to boot each 4th attempt.
> But, to my great disappointment, I still got exactly the same error.
> Can anyone offer any advice on how to:
> 1) Get my machine booting to a safe Snow Leopard install on the (now
> primary) HD?
>  2) Safely install Ubuntu on the (now secondary) SSD?
> Obviously the first is a top priority, as I need my machine in order to
> work!
> Then I can concentrate on moving my dev environment to Ubuntu, which I've
> been dying to do for ages.
> Thanks very much for any & all assistance.
>
> Bed, now. I hate going to sleep defeated, but I've no idea what else to do.
> 'Night!
>    Doug.
>
> PS -- apologies to any Geekuppers for the cross post.
>

If you have a time machine backup I'd do the following.
1. Grab the OSX install CD and throw it into the drive
2. Using that CD flatten the OSX drive using the disk utility on the CD
3. Reinstall OSX
4. Attach time machine disk and restore from backup.

Hope that helps.

-Matt Daubney
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20110430/4716454c/attachment.html>


More information about the ubuntu-uk mailing list