[ubuntu-uk] Using HTC phone via Ubuntu Internet connection

David King linuxman at avoura.com
Mon Nov 15 22:43:23 GMT 2010

Josh Holland wrote:
> On Fri, 2010-11-12 at 20:40 +0000, alan c wrote:
>> This is 'tethering' I believe.
>> On my Android Pulse (T Mobile brand) (early Android version too I 
>> guess), I found I needed an app.
> To drift slightly off the original topic, I also have a T-Mobile Pulse,
> which I could tether to my 10.04 (not needed to use it since upgrading
> to 10.10) netbook without having to install anything extra on either the
> phone or the computer. It was a simple case of plugging the phone in
> with the USB cable, then opening a terminal and using the command
> $ sudo modprobe usbserial vendor=0x1501 product=0x12d1
> (I can't remember the exact vendor/product numbers; you can check them
> by issuing the "lsusb" command.)
> The phone then appeared in the Network Manager applet, and could be
> selected and its internet used without any fuss.
> Josh

I tried various suggestions, but so far nothing works. The Ubuntu PC 
sees the phone on usb0, and it has an IP address, which I can 
successfully ping.

But on the phone, it just says under "Internet Pass-through" in the 
Wireless & Networks settings: "Turning on..." and this text is in grey 
with no sign of the phone connecting. And then it comes up with a dialog 
box on the phone saying it was unable to connect to PC.

I also tried connecting my phone to a friend's laptop running Ubuntu 
10.10 and it would not work there either.

The lsusb command gives the following info for the phone:

Bus 002 Device 008: ID 0bb4:0ff9 High Tech Computer Corp.

I assume therefore that your command you gave would be entered as:

$ sudo modprobe usbserial vendor=0x0bb4 product=0x0ff9

I could not find Network Manager, but I did try System/Administration/Network Tools (in Ubuntu 9.04).


More information about the ubuntu-uk mailing list