[ubuntu-uk] Using HTC phone via Ubuntu Internet connection - Tethering

alan c aeclist at candt.waitrose.com
Fri Nov 12 20:46:10 GMT 2010


On 12/11/10 20:40, alan c wrote:
> On 12/11/10 18:51, David King wrote:
>>  I have just bought a HTC Desire Z mobile phone, running Android 2.2.
>>
>>  It has a feature to allow, via the USB cable, use of the Internet
>>  connection on a PC so that the phone can connect via that, rather than
>>  use the 3G or wi fi when those are not available or not wanting to use
>>  them. I want to download lots of applications without draining my 3G
>>  data allowance.
>>
>>  I have searched via Google, and some people have said that it just
>>  worked for them. They plugged in the phone to their Ubuntu PC and they
>>  could use the Internet on the phone.
>>
>>  But I cannot get it to work. I am new to Android, and still figuring out
>>  the phone. In the Settings/Wireless&   Networks, there is an option for
>>  Internet Pass-through, which is trying to connect but never does. Then
>>  it comes up with a message saying:
>>  "Unable to connect to PC" and asks me to install HTC Sync software
>>  (which is Windows only).
>>
>>  Is there something I need to install in Ubuntu to get it to work?
>
> This is 'tethering' I believe.
>
> On my Android Pulse (T Mobile brand) (early Android version too I
> guess), I found I needed an app.
>
> Easy tether Lite works fine. It gave detailed instructions for
> installation in the phone, which all worked ok.
>
>   From the phone, using Android Market, I downloaded easytether lite,
> and part of this was a .deb file which I also needed to copy to the
> laptop and install in the laptop. I used the usb cable in sd card
> storage mode, to get the deb file over to the laptop.
>
> On the phone, after starting the easytether app, I enabled the usb
> tethering service (the app brings the request up).
>
> On the laptop, I need a terminal, and run
> easytether connect
>
> 'connection' is made, and indicated in the terminal.
>
> I open *another*  terminal and then run
> sudo dhclient easytether0
> [it is a zero]
>
> the firefox browser then just works, although ensure it has not set
> itself into offline mode....
>
> Having to use a coiuple of terminals is a bit fiddly  at first, but I
> soon got used to it.
>
> All of this is detailed in the easytether instructions when I used th
> eapp install, but on loking just now on the web I cannot obviously see
> it, it may be there somewhere of course.
>
> Have fun!
>
> I am using an early asus eeepc (900), with Ubuntu 10.04.1 netbook
> installed

Whoops!
Apologies, I did not read your post carefully at all, you have asked 
the reverse question..... sorry.
:-(

Anyway perhaps my wrong answer will help somebody else.
-- 
alan cocks
Ubuntu user



More information about the ubuntu-uk mailing list