[ubuntu-uk] DNS settings resetting[Solved]

Colin Law clanlaw at googlemail.com
Sun Jan 17 17:31:06 GMT 2010

2010/1/15 Colin Law <clanlaw at googlemail.com>:
> I am using Ubuntu 9.10 wired to a Linksys modem/router using DHCP to
> get IP etc.  All works fine normally and if I right click on the
> connection icon in the top panel and select Connection Information I
> see my IP address etc as expected, including Primary and Secondary DNS
> servers as provided by my ISP.
> Occasionally, however, once a day or so, the DNS values get set to
> (the router ip) and dns fails of course.  If I unplug my
> ethernet cable for a few seconds and plug it back in then it picks up
> the dns again and all is well.

I now see that I had completely misunderstood what is going on here.
Each morning I switch my laptop and modem/router on at the same time.
Ubuntu gets up and running and asks for IP address etc via DHCP.  At
this time the  router has not yet connected to the internet so it
gives the laptop an IP address but for the DNS it gives
(the router itself).  When the router connects to the internet it
picks up the actual DNS addresses (but does not pass those on to the
laptop of course as it is too late).  It appears that the router
successfully passes on DNS requests as the laptop then functions ok
for a couple of hours.  During this time the DNS used by the laptop is

At some point and for an unknown reason it appears the the router
stops passing on DNS requests and the laptop is unable to resolve
addresses.  I have confirmed that it is the router by configuring one
of my fixed ip address PCs to use for DNS and it fails at
the same time as the laptop.

If I then unplug the laptop ethernet cable and re-insert it, it asks
for ip renewal and this time is given the internet DNS addresses
directly so all is well again.

So in conclusion this is nothing to do with Ubuntu but is a problem
with the router failing to pass on DNS requests for some reason.  I
have worked around it by using fixed DNS in ubuntu network settings as
suggested by Dave Morely.  I may try defaulting the router to see if
it fixes it.  I am not trying this immediately as I am in the process
of switching ISP and do not wish to fiddle with anything until
switched over and all is stable.

Thanks all for your help


More information about the ubuntu-uk mailing list