[ubuntu-uk] DNS settings resetting

Colin Law clanlaw at googlemail.com
Fri Jan 15 11:38:11 GMT 2010

2010/1/15 Dave Morley <davmor2 at davmor2.co.uk>:
> On Fri, 2010-01-15 at 11:19 +0000, Colin Law wrote:
>> I am using Ubuntu 9.10 wired to a Linksys modem/router using DHCP to
>> get IP etc.  All works fine normally and if I right click on the
>> connection icon in the top panel and select Connection Information I
>> see my IP address etc as expected, including Primary and Secondary DNS
>> servers as provided by my ISP.
>> Occasionally, however, once a day or so, the DNS values get set to
>> (the router ip) and dns fails of course.  If I unplug my
>> ethernet cable for a few seconds and plug it back in then it picks up
>> the dns again and all is well.
>> I have looked for clues as to why the DNS settings might be
>> disappearing but have not found anything logged anywhere, suggestions
>> as to where to look for information would be much appreciated.  Or any
>> other ideas for that matter.
>> Colin
> daft question have you looked at the logs on the router in case it is
> nothing to do with Ubuntu?

I had not, but I have now.  It does not seem to log the DHCP requests
or any other communication between the PC and the router, or between
the router and the ISP, only stuff passing through it.  I cannot see
anything unexpected.

I suppose one possibility is that when the PC asks for the lease to be
renewed the router is not providing the DNS correctly.  That seems an
odd sort of fault however.  It has only recently started happening.


More information about the ubuntu-uk mailing list