[ubuntu-uk] Printer monitor needs older libs

Wulfy wulfmann at tiscali.co.uk
Wed Feb 17 21:02:24 GMT 2010

I wanted to check on the ink levels in my Canon PIXMA iP2500 printer.  
However, when I ran the monitor, it complained that a library couldn't 
be found. I ran "ldd" on the program and got this output ( I used the 
`which..` command because I don't know where the monitor lives....):

wulfy at wulfy-desktop:~$ ldd `which cngpijmonip2500`
        linux-gate.so.1 =>  (0x00978000)
*** libgtk-1.2.so.0 => not found
*** libgdk-1.2.so.0 => not found
*** libgmodule-1.2.so.0 => not found
*** libglib-1.2.so.0 => not found
        libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x0031e000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x009b7000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00fa7000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00110000)
        libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x006c8000)
*** libxml.so.1 => not found
        libcups.so.2 => /usr/lib/libcups.so.2 (0x0040c000)
        libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00451000)
        /lib/ld-linux.so.2 (0x00b76000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00cd6000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x002a7000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0023f000)
        libgnutls.so.26 => /usr/lib/libgnutls.so.26 (0x0035c000)
        libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0x00269000)
        libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0x00e08000)
        libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x00276000)
        libz.so.1 => /lib/libz.so.1 (0x002ee000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x0084d000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00596000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00ecd000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x00889000)
        libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x009a8000)
        libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x00e9d000)
        libresolv.so.2 => /lib/tls/i686/cmov/libresolv.so.2 (0x008a7000)
        libtasn1.so.3 => /usr/lib/libtasn1.so.3 (0x00945000)
        libgcrypt.so.11 => /lib/libgcrypt.so.11 (0x006ee000)
        libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x00322000)
        librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0x00290000)
        libgpg-error.so.0 => /lib/libgpg-error.so.0 (0x00d50000)

All the libraries are at 2.0.  How can I get the monitor program to use 
the updated libs?

Kubuntu Karmic 32-bit (I assume that it doesn't matter which flavour of 
*buntu as it's down at the driver level).

Linux wulfy-desktop 2.6.31-20-generic #57-Ubuntu SMP Mon Feb 8 09:05:19 
UTC 2010 i686 GNU/Linux



Wulf Credo:
Respect the elders. Teach the young. Co-operate with the pack.
Play when you can. Hunt when you must. Rest in between.
Share your affections. Voice your opinion. Leave your Mark.
Copyright July 17, 1988 by Del Goetz

More information about the ubuntu-uk mailing list