[ubuntu-uk] Network Manager

Grant Sewell dcglug at thymox.co.uk
Tue Aug 3 12:50:27 BST 2010

On Tue, 03 Aug 2010 12:39:49 +0100
gazz wrote:

> The network manager from 9.04 onwards drives me up the wall! I'm now
> using Lucid and I needed to install a wireless access point, the
> network manager wouldn't let me connect to its interface so I had to
> remove the network manager and put wicd on instead. OK, now I could
> set up the wireless access point, all well and good. 
> It seems that the sync for Ubuntu One and Dropbox need the network
> manager as both are acting crazy this morning. UbuntuOne can't connect
> at all and Dropbox is partially syncing. Anyway wicd can't seem to
> connect to the wifi at my workshop either. 
> Tried to remove wicd - no luck with apt-get. Had to purge it and
> reinstall network-manager with aptitude. Then the nm-applet indicator
> was missing from the tray and no way to interact with the network
> manager short of cli. Did killall nm-applet and then started it again
> - now it's hanging complaining: 
>     ** (nm-applet:1998: DEBUG: old state indicates that this was not a
> disconnect 0
> When I restart networking, it's using DHCP Client to reconnect. 
> I can find other people with similar issue but no-one seems to know
> what's going on. The only person who seems to have solved it
> reinstalled 10.04 from scratch! 
> So whenever I want to configure a router, I'll have to reinstall
> 10.04???? There has to be an easier fix? I frequently need to install
> routers . . . 

In my previous job I would routinely need to do the following to avoid
a similar situation:

+ kill the nm-applet
+ disable (temporarily) the Network Manager
  (sudo /etc/init.d/network-manager stop)
+ set IP manually or run dhclient manually

When all finished, clear the manual IP address (if any), restart
network-manager and re-run nm-applet and all was happy again.


More information about the ubuntu-uk mailing list