[ubuntu-uk] Kubuntu Hardy to Jaunty failed

Rob Beard rob at esdelle.co.uk
Fri Oct 16 20:41:22 BST 2009

Mark Fraser wrote:
> I've tried the Kubuntu mailinglist, but haven't had a response. So I thought 
> I'd try here.
> I tried to upgrade my wife's computer from Hardy to Jaunty this week after 
> successfully doing it on 2 other computers. This time it started coming up 
> with error messages saying certain packages couldn't be installed and stopped.
> I dropped into tty1 and carried on with the install there, but the part of the 
> upgrade where it removes old packages didn't happen.
> If I do
> apt-show-versions |grep hardy
> on the computer I'm presented with a whole list of packages that I presume 
> should have been removed. Can I safely remove all these packages?
> Also, if I do
> apt-show-versions |grep -v jaunty
> on my computer I have a list of packages that must've been from when I had 
> Gutsy.
Oh dear.  I'm sure it was discussed a week or so ago about upgrading 
between versions.  I gather it's not a good idea to upgrade from more 
than one version to another at a time, so I guess from Hardy, you'd need 
to upgrade to Intrepid, then Jaunty.

Fraid I can't help much other than suggest maybe looking at backing up 
the system, at least the home directory and then reinstalling from a 
fresh install of Jaunty.  Maybe someone else might be able to offer some 
more advice on how to fix it?


More information about the ubuntu-uk mailing list