[ubuntu-uk] Connecting to a network

David King linuxman at avoura.com
Sat Jul 11 22:55:24 BST 2009


I do have another problem, with the network.

I have put my Asus EeePC running Xandros on the network, and I want to 
connect to it from my Ubuntu PC and vice versa.
I have installed samba on Ubuntu, plus gadmin-samba, and Firestarter.

I have tried to set up the file sharing so that the Asus can access my 
home directory, and so that Ubuntu can access the Asus home directory.

But when trying to access Asus from Ubuntu, it asks for a username, 
domain and password. But when I entered the Asus username, the PC name, 
and the password, it would not connect. Error message: "Unable to mount 
location. Failed to mount Windows share."

And from the Asus, when I try to connect to the Ubuntu PC, I get an 
error saying "No route to host".

I have used networking successfully in the past. It was not difficult at 
all in Windows XP, 2000 and 98 (although I found it to be impossible in 
Windows ME).

I then started using Xandros, and networking with that was very easy. I 
have also networked PCs running other Linux distros, but when it comes 
to Ubuntu, I just cannot get it to work. I have tried in 7.10, 8.04 and 
now 9.04 -- I always get no access to other PCs on the network from 
Ubuntu, and no access to Ubuntu from other PCs. However, I can access my 
NAS okay from Ubuntu (as mentioned earlier, below).

So why is networking in Ubuntu so very difficult to set up? What is the 
magic thing I need to enter to make it work? Other distros make it much 
easier. Ubuntu did not even have Samba installed by default, so I fear I 
may still need to install another piece of software to make it all work.

Firestarter is set up to allow incoming traffic to all using Samba, and 
I specified the network by IP (192.168.0.2-192.168.0.255) and by name.

And when I try to access the Ubuntu network share via Network in 
Nautilus, which I should be able to do as it is the PC I am accessing it 
from, I get an error saying "Unable to mount location. Failed to 
retrieve share list from server."


So how do I get networking/filesharing working in Ubuntu?


David King




David King wrote:
> Thanks, Matthew, that worked perfectly. I have saved it in a script so 
> that I can mount the NAS from the CLI when I need to use it, and have 
> full read-write access.
>
>
> David King
>
>
> Matthew Daubney wrote:
>   
>>>     
>>>       
>> Hi David,
>>
>> You need to tell the mount line to override the uid and gid of the
>> files. This can be done with the options switch on the mount line like:
>>
>> sudo mount -t cifs '//192.168.0.4/DISK 1' /media/nas1 -o
>> uid=1000,gid=1000
>>
>> You'll need to look up the id for your user and your group, you can find
>> that info in /etc/group, which will look like "yourgroupname:x:gid:" and
>> in /etc/passwd.
>>
>> If you're the first user they'll probab;y both be 1000.
>>
>> Hope that helps!
>>
>> -Matt Daubney
>>
>>
>>
>>
>>   
>>     
>
>   



More information about the ubuntu-uk mailing list