[ubuntu-uk] Cannot print from Ubuntu

Paul Sutton zleap at zleap.net
Mon Jan 12 22:35:24 GMT 2009

David King wrote:
> I am having a problem with printing to my laser printer recently. 
> Although it is connected, the print jobs are not being sent. The 
> computer cannot seem to find the printer.
> The printer is a Brother HL-5150D, I am using Ubuntu 8.04.1. It is 
> connected via USB. The last time this happened, a few days ago, I 
> rebooted the PC and when I was logged in the page was printed without me 
> having to reprint it at all. It is like the computer cannot see the 
> printer, but is sending the print job, which gets stuck somewhere, and 
> will not go through unless the PC is rebooted. I used to have this 
> problem a few years ago, when using Windows on a different PC. I would 
> try to print, nothing happened, until I rebooted and then it printed.
> This problem has not occurred before with Ubuntu or any other Linux 
> distro and this printer, this is now the second time it has happened. I 
> tried unplugging the printer USB cable and reinserting, I tried 
> switching the printer off and on, I tried using the CUPS printer admin 
> page in Firefox (http://localhost:631/printers) to look at what is 
> happening, in that page I had to click on Start Printer but still 
> nothing comes out of the printer.
> David King
Ok totally dumb suggestion time, is there any paper in the printer

while windows can talk to printers and get messages back saying no 
paper, Iam not sure if Linux does this in the same way using cups,  I 
have a brother inkjet and it beeps if there is no paper,  but i don't 
get a screen message,

Also check ink / toner etc,  when you turn off,  just check the 
connections, unplug and push back in so you are happy they are connected 
properly, it rules things out.

hope this helps.


Paul Sutton
Support Open and ISO standard file formats e.g ISO 26300 odt
Next Linux User Group meet : Feb 7th : 3pm (TBC),  Shoreline Cafe Paignton

More information about the ubuntu-uk mailing list