[ubuntu-uk] Hooking up a machine running Ubuntu to a Mark 1 BTHomeHub

Lucy lucybridges at gmail.com
Thu Feb 19 12:38:44 GMT 2009

2009/2/19 Rowan <rowan.berkeley at googlemail.com>:
> hello again. I have consulted the manuals online, and it seems all
> routes lead me back to the Network Connections panel, in which the only
> connection I can see, when the Ethernet cable to the BT HomeHub is
> plugged in, is 'Point to Point', and nothing happens when I click it.
> When I tried to connect via a USB port, I saw a button for 'Wired
> Connection' too, but nothing happened when I clicked that either. There
> is also an 'unlock' button, but clicking that makes no difference.

The 'unlock' button will prompt you for a password and allow you to
make changes.

Is anything listed under the 'Wired' option?

> 'Enable Networking' is ticked. This is certainly a vital check to make.
> I tried typing 'sudo ipconfig' in the terminal and got this:
> Link encap: Local Loopback
> inet addr: Mask
> inet6 addr:: 1/128 Scope: Host
> (and then some MTU, Metric, RX packets, TX packets, errors, bytes, etc.)
> In other words, no interfaces at all.

You'll need to type  'sudo ipconfig -a' to show all interfaces,
including ones not currently in use.

Also, typing 'dmesg | grep eth0' as recommended by Nick to give us the
make of your network card is a good idea too.

I've forgotten the earlier part of the conversation, but has both the
HomeHub and ethernet cable been used successfully with other computers
in the past?

More information about the ubuntu-uk mailing list