[ubuntu-uk] System hosed during network upgrade to 8.10

George MacLeod bhaltair at gmail.com
Fri Oct 31 20:29:59 GMT 2008

2008/10/31 Alan Pope <alan at popey.com>

> 2008/10/31 George MacLeod <bhaltair at gmail.com>:
> > I have been using Ubuntu since 5.04 and have never had a major problem
> until
> > now. I have upgrade before via CD and via the network and always with
> only
> > minor issue, if any, until now. I ran the network upgrade as before to go
> > from 8.04 to 8.10 and everything went as it had in the past, until the
> final
> > stage when I was asked to OK the removal of obsolete packages. I thought
> > nothing of it as this is normal, but alarm bells stated ringing when I
> saw
> > Firefox, Evolution, compiz and Xorg being removed, but the process had
> > already started.
> >
> > I then clicked restart at the end and that's when I realised all was not
> > well
> This was possibly not wise. For future reference if you have a
> situation where the system is in a dodgy state, a restart is probably
> not the best course of action at that point.
> > I've tried to reboot several times with the same result and booting into
> > recovery mode just leaves me hanging at a terminal prompt.
> >
> A logon prompt? If so can you logon okay?
> > Needless to say I will not be upgrading any of my other machines until I
> can
> > get this fixed.
> Conversely I have upgraded 5 machines and not had this kind of issue.
> > My PC is a Dell Dimension Dual boot with XP on a corporate LAN.
> >
> What's the package history on the machine? Have you ever used
> automatix or something similar to install packages? What do you have
> in /etc/apt/sources.list and any files in /etc/apt/sources.list.d/ ?
> Is the "ubuntu-desktop" package still installed (assuming you can get
> logged in), type this:-
> dpkg -l ubuntu-desktop
> (that's a lower case L).
> Cheers,
> Al.
> --
> ubuntu-uk at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-uk
> https://wiki.ubuntu.com/UKTeam/
Thanks for the advice. I will try again on Monday as this is my work PC. On
this PC I have upgraded from 7.04 > 7.10 >8.04 over the network with no
problems at all. I did have Automatix way back but removed it long ago. The
machine has been very stable till now. I didn't get a logon prompt so will
have to think of another approach.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20081031/dfa6c43e/attachment.htm 

More information about the ubuntu-uk mailing list