[ubuntu-uk] df and du give different results

Stuart Bird e_tective at yahoo.co.uk
Thu Jan 3 14:53:47 GMT 2008


Have a poke around for hidden ".trash" folders, particularly on mounted media such as USB/Firewire hard drives. I have found that Ubuntu has a habit of creating these on such volumes and they do not appear to get emptied by the usual processes. I have often thought I had deleted files then realised that my disc space had not increased as a result, it was always a hidden trash file that was the culprit. Manually deleting the files from the trash files usually gets rid of them.

It may be the large volume you have at /media? that is hiding such a file. I'm not sure why that "hidden" data wiuld not be seen by df and du though?



----- Original Message ----
From: Chris Rowson <christopherrowson at gmail.com>
To: British Ubuntu Talk <ubuntu-uk at lists.ubuntu.com>
Sent: Thursday, 3 January, 2008 12:49:13 PM
Subject: [ubuntu-uk] df and du give different results


I'm running a Dapper webserver and I'm having terrible problems with
du and df giving different results:

df -h gives me.....

Filesystem            Size  Used Avail Use% Mounted on
                       29G   27G  347M  99% /
varrun                252M   52K  252M   1% /var/run
varlock               252M  4.0K  252M   1% /var/lock
udev                  252M   52K  252M   1% /dev
devshm                252M     0  252M   0% /dev/shm
                      1.4T  710G  671G  52% /media/netbackup
/dev/sda5             228M   14M  203M   7% /boot

sudo du -hs /* gives me.....

3.1M    /bin
9.4M    /boot
0       /cdrom
172K    /dev
2.6M    /etc
39M     /home
4.0K    /initrd
0       /initrd.img
76M     /lib
48K     /lost+found
263G    /media
4.0K    /mnt
4.0K    /opt
514M    /proc
20K     /root
8.1M    /sbin
4.0K    /srv
0       /sys
12K     /tmp
263M    /usr
14G     /var
0       /vmlinuz

Now that just doesn't add up.

I wondered if it might be a problem with open files, so I've tried

lsof | grep deleted and lsof | grep DEL

They showed Apache2 and MySQL had some files open so I restarted them.
This didn't help so I restarted the server. Still no joy!!

Please help me :-O


ubuntu-uk at lists.ubuntu.com

Sent from Yahoo! Mail - a smarter inbox http://uk.mail.yahoo.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20080103/7ca6c23c/attachment.htm 

More information about the ubuntu-uk mailing list