[ubuntu-uk] killed box through /var :P

Farran fazzy.baboon at ntlworld.com
Mon Dec 22 12:33:37 GMT 2008

hi everyone again
sorry this is awfully complicated, but stick at it if you can be
bothered :D I try to make sense of it at the end.

following my previous question about compiz, I realised the issue was
with space on my / partition - every time I tried to do something, it
complained (which was when I noticed). I had only set aside 15gb for
the /, and I'm a bit of a program whore :D so I managed to fill it up.
So much so, that synaptic could not start because there was not enough
space to write an index of installed packages!
    The only option I could think of was to move data to another
partition (I have two more 15gb sections, originally set aside to play
with other OSes) and remount it in the correct place. Looking through
the different system folders, I discovered /var was almost the biggest,
so moved that - by setting up a /var2 and mounting another partiton to
it. I moved everything over, and remounted it over /var. The only issue
was that none of the socket files would move. I figured I could move
them over later on. I also felt comfortable with it because when the
moved files were in the wrong place, an error popped up (about dpkg).
When I remounted it, the error vanished, so I presumed it was ok. I
edited /etc/fstab to mount /dev/sda6 to /var2 (not /var which was
silly). Another weird thing - every time I removed anything through
synaptic - however big or small - no space was ever freed up. I
transferred 6.2gb of /var to the other partition, and there's only 5.4gb
space left on /.
    After rebooting, it worked fine, but I wasn't happy with it being
spread around, so I looked through synaptic to try and remove stuff so I
could put /var back on the same partition as the rest of it. [Also
playing around with xorg.conf, I ran the reconfigure command it gave me
in the file (no manual editing!). This might have some relation to the
next bit cos it links to the input devices.] But now it won't/can't
start gdm or X because /var is all in /var2. It needs xauthority
from /var/lib/gdm. I tried to re-edit fstab with vi, but I don't know
how to use it and I have no help file - how do I save it? But even when
I mount sda6 to /var, gdm starts and logs on, but nothing works apart
from <control><alt>F1-F12 and Delete. And the mouse doesn't do anything.

Another option I was going to try is repartitioning - through another
[live] os. Delete a spare 15gb, move everything up and resize the /
partition. But I'm scared of accidentally formatting something or wiping
something off, and ending up with no boot flag.

Err that probably made no sense, but if you can get anything out of
that, my main questions are:
1 is repartitioning safe and preferable?
2 how do I use vi?
3 what are the commands to move /var2 back to /var (I think I know but
don't want to make it worse)
4 would it be best to generate an install list from synaptic so I know
what I've got, and do a clean install with a larger partition? (and how
would I do this through aptitude command line - I have no gui at all

I'm thinking number 4 would be easiest and better for my ubuntu - but I
want my pc working cos I'm just about to get internet in my room :(

Farran Lee
I'm only 16 :-P
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20081222/e105c583/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smiley-10.png
Type: image/png
Size: 848 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20081222/e105c583/attachment.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smiley-6.png
Type: image/png
Size: 796 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20081222/e105c583/attachment-0001.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smiley-1.png
Type: image/png
Size: 798 bytes
Desc: not available
Url : https://lists.ubuntu.com/archives/ubuntu-uk/attachments/20081222/e105c583/attachment-0002.png 

More information about the ubuntu-uk mailing list