[Bug 651357] [NEW] 'Network error' on attempting to connect to GTalk account on Maverick Empathy

Rob Parker rob at iparker.co.uk
Wed Sep 29 18:03:00 UTC 2010


Public bug reported:

Binary package hint: empathy

When adding a 'Google Talk' account in Empathy on Maverick (amd64), I
always receive 'Disconnected - Network error' - however if I add the
same Google account (with same username and password) using the 'Jabber'
(which should surely be 'XMPP' nowadays?) account type Empathy is able
to connect successfully. Testing different states of the 'Encryption
required (SSL)' and 'Ignore SSL certificates errors' options does no
appear to fix the issue.

The only possible cause on my part could be that I am behind a rather
strict university firewall - however I have had the port used by Google
Talk and most other XMPP services - TCP 5222 - unblocked, and hence
Pidgin, and the aforementioned Jabber account type in Empathy, are able
connect fine (they were not prior to having this unblocked).

Steps to reproduce:
1. Start Empathy.
2. If the 'Messaging and VoIP Accounts' window has not already opened, open it from Edit > Accounts in the 'Contact List' window.
3. Click the 'Add...'  button.
4. Set the 'Protocol' to 'Google Talk'.
5. Enter a valid Google account's username (the full email address, including the domain) and password in the 'User ID' and 'Password' boxes.
6. Click the 'Log in' button.
7. Note how red-background messages appear in both the 'Messaging and VoIP Accounts' and 'Contact List' windows.
8. Use the 'Remove' button to delete the account, and repeat the process from steps 3-6, but this time use 'Jabber' as the protocol instead of 'Google Talk', and note how the connection succeeds.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: empathy 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic x86_64
NonfreeKernelModules: nvidia wl
Architecture: amd64
Date: Wed Sep 29 18:38:52 2010
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100915)
ProcEnviron:
 LANG=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: empathy
XsessionErrors:
 (polkit-gnome-authentication-agent-1:1655): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:1656): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
 (Tomboy:1642): Gdk-CRITICAL **: IA__gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed

** Affects: empathy (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug maverick

-- 
'Network error' on attempting to connect to GTalk account on Maverick Empathy
https://bugs.launchpad.net/bugs/651357
You received this bug notification because you are a member of
Telepathy, which is subscribed to empathy in ubuntu.




More information about the Ubuntu-telepathy mailing list