[Bug 435262] [NEW] Segfault at starting (probable cause :libindicate patch )

Laurent Claessens moky.math at gmail.com
Wed Sep 23 13:31:54 UTC 2009


Public bug reported:

I'm forwarding a bug from upstream.
https://bugzilla.gnome.org/show_bug.cgi?id=595980

Empathy has a segfault when starting. Here is the backtrace from gdb:

#0  0x0056e1e3 in g_type_check_instance () from /usr/lib/libgobject-2.0.so.0
#1  0x0056a0b5 in g_signal_connect_data () from /usr/lib/libgobject-2.0.so.0
#2  0x0806e6ea in empathy_event_manager_init (manager=0x81eb828) at empathy-event-manager.c:1059
#3  0x005768cf in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#4  0x0055b6f8 in ?? () from /usr/lib/libgobject-2.0.so.0
#5  0x0806e47b in event_manager_constructor (type=135073712, n_props=0, props=0x0) at empathy-event-manager.c:973
#6  0x0055c8ec in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#7  0x0055d4ea in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#8  0x0055d66e in g_object_new () from /usr/lib/libgobject-2.0.so.0
#9  0x0806e2bb in empathy_event_manager_dup_singleton () at empathy-event-manager.c:1066
#10 0x0807de46 in empathy_indicator_manager_init (manager=0x81e9420) at empathy-indicator-manager.c:354
#11 0x005768cf in g_type_create_instance () from /usr/lib/libgobject-2.0.so.0
#12 0x0055b6f8 in ?? () from /usr/lib/libgobject-2.0.so.0
#13 0x0807dcfb in indicator_manager_constructor (type=136257312, n_props=0, props=0x0) at empathy-indicator-manager.c:311
#14 0x0055c8ec in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#15 0x0055d4ea in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x0055d66e in g_object_new () from /usr/lib/libgobject-2.0.so.0
#17 0x0807dbfb in empathy_indicator_manager_dup_singleton () at empathy-indicator-manager.c:267
#18 0x08075beb in empathy_main_window_show () at empathy-main-window.c:1258
#19 0x0805bac1 in main (argc=1, argv=0xbffff7f4) at empathy.c:868

As far as I tested bug impactes the version 2.28.0, but not the 2.27.*
branch.

Remark 1 : this bug could be KDE-specific in the sense that I don't have the crash when I start Empathy in Gnome.
Remark 2 : when I launch Empathy in Valgrind, I don't have the problem. I attach the log of Valgrind (but it does not contains the segfault)

** Affects: empathy (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Segfault at starting (probable cause :libindicate patch )
https://bugs.launchpad.net/bugs/435262
You received this bug notification because you are a member of
Telepathy, which is subscribed to empathy in ubuntu.




More information about the Ubuntu-telepathy mailing list